Bug #56307

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Bug #52949: Speed decrease since 4.5

Findings from Bootstrap/PackageManager/ClassLoader analyses

Added by Steffen Ritter almost 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
Performance
Target version:
-
Start date:
2014-02-26
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Files

changes.diff (111 KB) changes.diff Some of the changes already done and tested in "one big block" Steffen Ritter, 2014-02-26 13:52

Subtasks

Bug #56308: ClassLoaderCache superflouousClosed2014-02-26

Actions
Bug #56310: The PackageManager checks every boot if all required packages are activeClosedThomas Maroschik2014-02-26

Actions
Bug #56311: PackageFactory does not need to be initialized on regular requestsClosedThomas Maroschik2014-02-26

Actions
Bug #56312: Dependency Resolver does not need to be initializedClosedBenni Mack2014-02-26

Actions
Bug #56313: Cache Identifiers shorten the MD5 hashClosed2014-02-26

Actions
Bug #56314: setCacheHashOptions from Bootstrap not relevant for EIDClosedBenni Mack2014-02-26

Actions
Bug #56315: Optimize TimeTracking init in eID CaseRejected2014-02-26

Actions
Bug #56316: inline BEUserAuth::getCookieNameClosedThomas Maroschik2014-02-26

Actions
Bug #56317: Cache Local and Default Configuration to prevent duplicate File AccessRejected2014-02-26

Actions
Bug #56318: Check wether the ConfigurationManager can be omitted/reduced for the purpose of what the Boostrap really needs from thatClosed2014-02-26

Actions
Bug #56319: Merge Cache/Cache and CacheFactory into CacheManagerClosed2014-02-26

Actions
Bug #56320: Check emptying the Flow Classes as far as possibleRejected2014-02-26

Actions
Bug #56322: GetAliasesForClass not usedClosed2014-02-26

Actions
Bug #56323: cache_classes should cluster by Package instead of ClassClosed2014-02-26

Actions
Bug #56324: Class Loader should not try to runtime resolve class-pathesClosed2014-02-26

Actions
Bug #56325: Move "finalClassNameCache" from GeneralUtility to ClassLoaderClosed2014-02-26

Actions
Bug #56326: Evaluate and Merge ClassAliasMap into Classloader classRejected2014-02-26

Actions
Bug #56328: Extract complex "class loader cache building" code into ClassLoadingInformationFactoryClosed2014-02-26

Actions
Bug #56330: Add all classes which are needed anyhow within the minimal Bootstrap to the require list in system environment builderRejected2014-02-26

Actions
Bug #56331: Evaluate if we can profit from concatenate all baseRequiredClasses into one fileClosed2014-02-26

Actions
Bug #56333: MicroOptimize ClassLoaderClosed2014-02-26

Actions
Bug #56334: Prevent inclusion of LogLevel due to ConfigDefault referralRejected2014-02-26

Actions
Bug #56335: Prevent Inclusion of ResourceStorage from BootstrapClosedThomas Maroschik2014-02-26

Actions
Bug #56336: Prevent Inclusion of MediaWizardProvider* in Base BootstrapClosed2014-02-26

Actions
Bug #56337: Remove manual array calculation in Locales and put the arrays to the class directlyClosed2014-02-26

Actions
Bug #56340: Remove the VariableFrontend from requiredBaseClassesClosed2014-02-26

Actions
Task #56341: Evaluate if it is really reasonable to have TYPO3\CMS\Core\Compatibility\LoadedExtensionsArrayClosedSteffen Ritter2014-02-26

Actions
Task #56538: Cache the $GLOBALS['TYPO3_LOADED_EXT'] as an arrayClosedThomas Maroschik2014-03-04

Actions
Bug #56933: Cached class loader misses are not considered on retrievalClosedThomas Maroschik2014-03-15

Actions
Task #56934: Move information in Package classes into composer filesClosedThomas Maroschik2014-03-15

Actions
#2

Updated by Thomas Maroschik over 6 years ago

  • Parent task set to #52949
#3

Updated by Riccardo De Contardi over 4 years ago

  • Category set to Performance
#4

Updated by Benni Mack about 3 years ago

  • Status changed from Accepted to Closed

Also available in: Atom PDF