Bug #56335

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Bug #52949: Speed decrease since 4.5

Bug #56307: Findings from Bootstrap/PackageManager/ClassLoader analyses

Prevent Inclusion of ResourceStorage from Bootstrap

Added by Steffen Ritter over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Category:
-
Target version:
-
Start date:
2014-02-26
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Associated revisions

Revision 9a735f28 (diff)
Added by Thomas Maroschik over 5 years ago

[BUGFIX] Prevent Inclusion of ResourceStorage from Bootstrap

During bootstrapping the ResourceStorage and ResourceFactory
is loaded and evaluated just because of two constants containing
signal names used in ext_localconf. This introduces unnecessary
overhead especially in eID context.

The constants have been extracted to an interface that are way
faster parsed.

Resolves: #56335
Releases: 6.2
Change-Id: I509593d2720c595fa7e4f1c9b5c63fd09fea724c
Reviewed-on: https://review.typo3.org/28416
Reviewed-by: Wouter Wolters
Reviewed-by: Steffen Ritter
Tested-by: Steffen Ritter
Reviewed-by: Philipp Gampe
Tested-by: Philipp Gampe

History

#1 Updated by Thomas Maroschik over 5 years ago

  • Status changed from New to Accepted
  • Assignee set to Thomas Maroschik

#2 Updated by Gerrit Code Review over 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28416

#3 Updated by Gerrit Code Review over 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28416

#4 Updated by Thomas Maroschik over 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF