Bug #56337

Epic #55070: Workpackages

Epic #55065: WP: Overall System Performance (Backend and Frontend)

Bug #52949: Speed decrease since 4.5

Bug #56307: Findings from Bootstrap/PackageManager/ClassLoader analyses

Remove manual array calculation in Locales and put the arrays to the class directly

Added by Steffen Ritter over 5 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2014-02-26
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

the constructor calculates the same stuff over and over again on __construct() each request.... We are talking about a small count of vlaues: hardcode them

History

#1 Updated by Stephan Großberndt about 5 years ago

You are talking about TYPO3\CMS\Core\Localization\Locales?

It implements \TYPO3\CMS\Core\SingletonInterface, initialize() it is only called once per request.

$instance->languages and $instance->localeDependencies cannot be put in the class because of user-defined locales.

The only optimization possible would be to remove

$instance->isoMapping = array_flip($instance->isoReverseMapping);

and put the "->isoMapping" array into the class hardcoded.

Is this what you intended with this bug report?

#2 Updated by Stephan Großberndt over 4 years ago

Steffen, can you please explain what was intended here?

#3 Updated by Wouter Wolters about 4 years ago

  • Status changed from New to Needs Feedback

#4 Updated by Morton Jonuschat almost 4 years ago

  • Status changed from Needs Feedback to Closed

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF