Bug #56353

SQL Error in sys_refindex on saving records with tca/flexform type group internal_type file

Added by Marc Bastian Heinrichs over 8 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Category:
DataHandler aka TCEmain
Target version:
Start date:
2014-02-26
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

caller     TYPO3\CMS\Core\Database\DatabaseConnection::exec_INSERTquery
ERROR     Column 'ref_table' cannot be null
lastBuiltQuery     INSERT INTO sys_refindex (tablename,recuid,field,flexpointer,softref_key,softref_id,sorting,deleted,ref_table,ref_uid,ref_string,hash) VALUES ('tx_impexpgroupfiles_item','1','images','','','','0','0',NULL,NULL,'','bd4e53ee65b4927172175e806f7f389a')
debug_backtrace     TYPO3\CMS\Backend\Controller\EditDocumentController->processData#48 // TYPO3\CMS\Core\DataHandling\DataHandler->process_datamap#516 // TYPO3\CMS\Core\DataHandling\DataHandler->updateDB#1222 // TYPO3\CMS\Core\DataHandling\DataHandler->updateRefIndex#5851 // TYPO3\CMS\Core\Database\ReferenceIndex->updateRefIndexTable#6008 // TYPO3\CMS\Core\Database\DatabaseConnection->exec_INSERTquery#120 // TYPO3\CMS\Core\Database\DatabaseConnection->debug#203

Related issues

Related to TYPO3 Core - Task #56352: Impexp: Files of TCA type "group" internal_type "file" are missing in exportClosedMarc Bastian Heinrichs2014-02-26

Actions
Related to TYPO3 Core - Task #56991: RefIndex is broken for FlexForm fields group file_reference, results in missing these files in exportClosedMarc Bastian Heinrichs2014-03-17

Actions
#1

Updated by Bernhard Kraft over 8 years ago

Fixing this bug is somehow prohibited by the following bug:

http://i.imgur.com/3MgE6bi.png

Which results in:

http://i.imgur.com/xWynWgs.png

... and both of those bugs inhibit properly testing this issue (Can't upload images)

Sorry! The problem was that I did not run the upgrade wizard.
False alarm.

#2

Updated by Gerrit Code Review over 8 years ago

  • Status changed from New to Under Review

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27310

#3

Updated by Gerrit Code Review over 8 years ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27310

#4

Updated by Gerrit Code Review over 8 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27310

#5

Updated by Gerrit Code Review over 8 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27310

#6

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28021

#7

Updated by Gerrit Code Review over 8 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27310

#8

Updated by Marc Bastian Heinrichs over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#9

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28795

#10

Updated by Gerrit Code Review over 8 years ago

Patch set 1 for branch TYPO3_6-0 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28796

#11

Updated by Marc Bastian Heinrichs about 8 years ago

  • Status changed from Under Review to Resolved
#12

Updated by Benni Mack almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF