Task #56352

Epic #55070: Workpackages

Epic #54542: WP: Importer / Exporter with relations MM/IRRE/FAL

Story #55520: As an User I want to create exports in v. 6.2 and import them in v. 6.2

Impexp: Files of TCA type "group" internal_type "file" are missing in export

Added by Marc Bastian Heinrichs almost 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Category:
Import/Export (T3D)
Target version:
Start date:
2014-02-26
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

this is related to commits:

and to patch

Related issues

Related to TYPO3 Core - Bug #49538: No references displayed in filelist for "internal_type" -> "file_reference" TCA fields Closed 2013-07-01
Related to TYPO3 Core - Feature #33751: Make use of File Abstraction Layer in Backend Closed 2012-02-07
Related to Grid Elements (former official tracker) - now moved to Gitlab! - Bug #55380: SQL Error when choosing flexform file Closed 2014-01-28
Related to TYPO3 Core - Bug #56353: SQL Error in sys_refindex on saving records with tca/flexform type group internal_type file Closed 2014-02-26
Related to TYPO3 Core - Task #56071: Impexp: add test scenarios for tca types group file and file reference Closed 2014-02-18
Related to TYPO3 Core - Task #56991: RefIndex is broken for FlexForm fields group file_reference, results in missing these files in export Closed 2014-03-17

Associated revisions

Revision 53c6adc8 (diff)
Added by Marc Bastian Heinrichs almost 6 years ago

[BUGFIX] Fields of type group file are not properly indexed

If an record with a field of type "group", internal_type "file"
should be indexed in the ReferenceIndex an SQL error exception
gets thrown. So the relation to the file isn't represented in the
refindex. Thus those files are also missing in exports created
with system extension impexp.

This is caused by wrong array keys and incorrectly storing a file
relation as DB relation since merge of FAL.

Resolves: #56353
Resolves: #56352
Releases: 6.2, 6.1, 6.0
Change-Id: I78211efcb6bf3032811ef0b0e20ed7f98f9fa8fb
Reviewed-on: https://review.typo3.org/27310
Tested-by: Sebastian Fischer
Tested-by: Christian Zenker
Reviewed-by: Wouter Wolters
Reviewed-by: Anja Leichsenring
Tested-by: Anja Leichsenring

Revision 1dbfe75e (diff)
Added by Marc Bastian Heinrichs almost 6 years ago

[BUGFIX] Fields of type group file are not properly indexed

If an record with a field of type "group", internal_type "file"
should be indexed in the ReferenceIndex an SQL error exception
gets thrown. So the relation to the file isn't represented in the
refindex. Thus those files are also missing in exports created
with system extension impexp.

This is caused by wrong array keys and incorrectly storing a file
relation as DB relation since merge of FAL.

Resolves: #56353
Resolves: #56352
Releases: 6.2, 6.1, 6.0
Change-Id: I78211efcb6bf3032811ef0b0e20ed7f98f9fa8fb
Reviewed-on: https://review.typo3.org/28795
Reviewed-by: Marc Bastian Heinrichs
Tested-by: Marc Bastian Heinrichs

Revision 75f6b1b6 (diff)
Added by Marc Bastian Heinrichs almost 6 years ago

[BUGFIX] Fields of type group file are not properly indexed

If an record with a field of type "group", internal_type "file"
should be indexed in the ReferenceIndex an SQL error exception
gets thrown. So the relation to the file isn't represented in the
refindex. Thus those files are also missing in exports created
with system extension impexp.

This is caused by wrong array keys and incorrectly storing a file
relation as DB relation since merge of FAL.

Resolves: #56353
Resolves: #56352
Releases: 6.2, 6.1, 6.0
Change-Id: I78211efcb6bf3032811ef0b0e20ed7f98f9fa8fb
Reviewed-on: https://review.typo3.org/28796
Reviewed-by: Marc Bastian Heinrichs
Tested-by: Marc Bastian Heinrichs

History

#1 Updated by Marc Bastian Heinrichs almost 6 years ago

  • Status changed from New to Accepted
  • Assignee set to Marc Bastian Heinrichs

#2 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Accepted to Under Review

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27310

#3 Updated by Gerrit Code Review almost 6 years ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27310

#4 Updated by Gerrit Code Review almost 6 years ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27310

#5 Updated by Gerrit Code Review almost 6 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28021

#6 Updated by Gerrit Code Review almost 6 years ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/27310

#7 Updated by Marc Bastian Heinrichs almost 6 years ago

  • % Done changed from 0 to 90

#8 Updated by Marc Bastian Heinrichs almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 90 to 100

#9 Updated by Gerrit Code Review almost 6 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28795

#10 Updated by Gerrit Code Review almost 6 years ago

Patch set 1 for branch TYPO3_6-0 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/28796

#11 Updated by Marc Bastian Heinrichs almost 6 years ago

  • Status changed from Under Review to Resolved

#12 Updated by Anja Leichsenring about 4 years ago

  • Sprint Focus set to On Location Sprint

#13 Updated by Mathias Schreiber over 3 years ago

  • Sprint Focus deleted (On Location Sprint)

#14 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF