Bug #56371

Strange behavior when renaming pages in the pagetree

Added by Alexander Stehlik over 6 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Pagetree
Target version:
Start date:
2014-02-27
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
5.4
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Steps to reproduce:

  • Edit a page by using double click on the pagename, enter a new pagename
  • do NOT! press Enter
  • double click on another page in the tree (while the first input field is still active)

Now you should see two errors:

  1. If you just press ENTER in the next page without renaming it, it will get the name of the previously edited page
  2. When you double click on on the first page again, you will see its old name in the input field until you reload the pagetree.

Associated revisions

Revision 539644a7 (diff)
Added by Martin Gebert over 4 years ago

[BUGFIX] Change name of correct pagetree entry after renaming

  • The first parameter to TreeEditor.complete and
    TreeEditor.beforecomplete is the TreeEditor, not the edited node.
    Reflect this in the code.
  • In TreeEditor.updateNodeText, update the node provided as parameter
    instead of the current editNode.
  • In saveTitle, remove the first parameter, because it's used in the
    wrong way (code assumes i'ts a node, but it's actually a TreeEditor) and
    is not necessary.
  • In saveTitle, store the current editNode, in case treeEditor.editNode
    changes before the ajax call completes.

Resolves: #56371
Releases: master
Change-Id: I9446969701f0e24bcc048305ea06819228982826
Reviewed-on: https://review.typo3.org/44977
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Reviewed-by: Michael Oehlhof <>
Tested-by: Michael Oehlhof <>
Reviewed-by: Andreas Fernandez <>
Tested-by: Andreas Fernandez <>

History

#1 Updated by Mathias Schreiber over 5 years ago

  • Description updated (diff)
  • Target version set to 7.4 (Backend)

confirmed on master

#2 Updated by Susanne Moog almost 5 years ago

  • Target version changed from 7.4 (Backend) to 7.5

#3 Updated by Benni Mack over 4 years ago

  • Target version changed from 7.5 to 8 LTS

#4 Updated by Gerrit Code Review over 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44977

#5 Updated by Gerrit Code Review over 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44977

#6 Updated by Anonymous over 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Riccardo De Contardi over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF