Bug #57264

Extension manager fails to update extensions that are needed by other extensions

Added by Philipp Gampe about 7 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
2014-03-25
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.0
PHP Version:
5.5
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

Updating an extension that is needed by another extension fails, because the extensions cannot be disabled temporarily during extension update.

This issue exists since 6.0.

Workaround: Disable all depending extensions beforehand.


Related issues

Related to TYPO3 Core - Bug #51572: Extensions order changing in LocalConfiguration.php during extensions updateClosedNicole Cordes2013-08-30

Actions
Has duplicate TYPO3 Core - Bug #57876: Extension Manager crashes on extension update with extension dependencyClosed2014-04-13

Actions

Also available in: Atom PDF