Project

General

Profile

Actions

Task #57546

closed

Call ExtractionService on new files and not only Indexer::createIndexEntry()

Added by Alexander Opitz about 10 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2014-04-02
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
medium
Sprint Focus:

Description

If a new file is found in a storage the function Indexer::createIndexEntry() is called, but a possible ExtractionService isn't signaled.


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #56959: FAL Extractor partially brokenClosedMathias Schreiber2014-03-16

Actions
Is duplicate of TYPO3 Core - Feature #56726: Trigger MetaDataExtraction after file uploadClosed2014-03-10

Actions
Actions #1

Updated by Sebastian Fischer about 10 years ago

ExtranctionServices are only called in Indexer::runMetaDataExtraction which is only called in FileStorageExtractionTask. I assume that this is to prevent to long processing calls.

Actions #2

Updated by Markus Klein about 10 years ago

Maybe Steffen R. can shed some light on this.

Actions #3

Updated by Steffen Ritter about 10 years ago

Yes, that's not a Bug, that is a feature.

MetaDataExtraction only will be done asynchronously with a dedicated scheduler task.

Actions #4

Updated by Alexander Opitz about 10 years ago

That leads to the problem, that you can select a file as image but it won't be shown in FE (or shown with width/height=0).

Actions #5

Updated by Frans Saris almost 9 years ago

  • Status changed from Accepted to Resolved
Actions #6

Updated by Benni Mack over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF