Bug #57587

Admin BE user records should ignore db mounts

Added by Pascal Dürsteler over 7 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
Start date:
2014-04-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
4.5
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Admin BE users are processing defined db mounts, which leads to an unnecessary big page tree because of the selected db mounts displayed in addition to the default root(uid 0).

How to reproduce
  1. Create a backend user without setting the admin flag and set a db mount.
  2. Edit the newly created user and set the admin flag. The db mount fields disappear, but are still taken into account.

Appears in 4.5 and 6.2 (didn't tested other versions).


Related issues

Related to TYPO3 Core - Bug #61704: Filemounts do not show up for Admin usersClosed2014-09-18

Actions
Related to TYPO3 Core - Bug #56990: If user is admin, the home directory of users and groups are not mountedRejectedMathias Schreiber2014-03-17

Actions
Related to TYPO3 Core - Bug #70493: Revert "[BUGFIX] Admin users should ignore user mounts"Closed2015-10-08

Actions

Also available in: Atom PDF