Bug #57805

SQL-ERROR: Specified key was too long

Added by Ben van 't Ende over 6 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
Start date:
2014-04-10
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In the upgrade process from 6.0 to 6.2 I get this error

Update failed!
SQL-ERROR: Specified key was too long; max key length is 1000 bytes
Update database schema: Modify tables and fields
ALTER TABLE sys_file_processedfile CHANGE identifier identifier varchar(512) default ''; 

Files

forge_57805.png (23.5 KB) forge_57805.png Oliver Hader, 2014-04-28 17:34

Related issues

Related to TYPO3 Core - Bug #56786: Index on sys_file_processedfile is too largeClosedErnesto Baschny2014-03-11

Actions
Related to TYPO3 Core - Bug #57002: SQL-Errors while Upgrading the database with Upgrade WizardClosed2014-03-17

Actions
Related to TYPO3 Core - Bug #57421: Update database scheme still failsClosedNicole Cordes2014-03-28

Actions
#1

Updated by Markus Klein over 6 years ago

  • Category set to Install Tool
  • Status changed from New to Accepted
  • Priority changed from Should have to Must have
  • Target version set to next-patchlevel

Happens on upgrading from 6.x.

#2

Updated by Markus Klein over 6 years ago

In 6.0 the identifier field has varchar(200).
The wizard tries to extend the field to varchar(512) which fails somehow.

I suspect the reason is the associated index with the same name.
Maybe it helps to remove the index first (manually in the DB) and let the wizard try the step again. It should then be able to extend the field and re-create the index automatically.

#3

Updated by Oliver Hader over 6 years ago

The reason seems to be the processing order and the fact the the existing index is not limited. Thus, it should be:

  1. drop index (DROP KEY identifier)
  2. modify field (CHANGE identifier)
  3. create index (ADD KEY identifier)
#4

Updated by Markus Klein over 6 years ago

That's what I wrote above. But do we have a chance to do that automatically?

#5

Updated by Nicole Cordes over 6 years ago

  • Status changed from Accepted to Resolved

This issue was solved with patch for http://forge.typo3.org/issues/57421

#6

Updated by Benni Mack about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF