Bug #58914

Cursor position is at the beginning of the segment after pasting

Added by Lorenz Ulrich about 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2014-05-19
Due date:
% Done:

0%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When I insert text from the clipboard, the cursor position after pasting is always at the beginning of the segment, where I would expect it to be at the end of the inserted segment.

Tested in Chrome and Firefox.

History

#1 Updated by Markus Klein about 6 years ago

  • Status changed from New to Accepted
  • Assignee set to Stanislas Rolland

Stanislas, can you take a look please?

#2 Updated by Stanislas Rolland about 6 years ago

Lorenz Ulrich wrote:

When I insert text from the clipboard, the cursor position after pasting is always at the beginning of the segment, where I would expect it to be at the end of the inserted segment.

Tested in Chrome and Firefox.

What is the selected paste behaviour?

#3 Updated by Lorenz Ulrich about 6 years ago

You mean the desired? Normally, when you insert content in an application (Word etc.), the cursor is at the end of the inserted segment.

#4 Updated by Stanislas Rolland about 6 years ago

No, I mean the paste behaviour set in User settings. You may paste as text, paste text with structure only, or normal (browser native) paste.

#5 Updated by Lorenz Ulrich about 6 years ago

Got it. The setting is "paste as plain text".

#6 Updated by Lorenz Ulrich over 5 years ago

Any news on that?

#7 Updated by Stanislas Rolland over 5 years ago

Well, I just tested this again in Firefox and Chrome and TYPO3 CMS master. In both browsers, the cursor is positioned after the paste text.

#8 Updated by Stanislas Rolland over 5 years ago

  • Status changed from Accepted to Needs Feedback

#9 Updated by Lorenz Ulrich about 5 years ago

Sorry, didn't watch this. Will test again next week.

#10 Updated by Lorenz Ulrich about 5 years ago

We can still reproduce this in 6.2 with Firefox and Chrome for Windows. Could you check if it works for you in 6.2?

#11 Updated by Alexander Opitz almost 5 years ago

  • Status changed from Needs Feedback to New

#12 Updated by Riccardo De Contardi over 3 years ago

  • Status changed from New to Needs Feedback

I am not able to reproduce it with 6.2.26 and 7.6.13

Could someone confirm? Or give a detailed (step by step) procedure about how to reproduce it? Thanks

#13 Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Stanislas Rolland)

No feedback since 90 days > closing.

If you think that this is the wrong decision or experience the issue again please reopen it. Or open a new issue with a reference to this one. Thank you.

Also available in: Atom PDF