Bug #59562

WebKit may insert a span element when backspacing an heading

Added by Wouter Beeftink over 7 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2014-06-13
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When removing a block format (h2, p) from an element in the RTE, the following element (for example the next paragraph) gets an inline span and inline CSS. That shouldn't happen.

To reproduce you can do the following:

  1. Create a content element (for example "text").
  2. Add a header with some text.
  3. Add a paragraph with some text after the header.
  4. Clear the header using the backspace key.
  5. Delete the empty line left by the header using the delete key.
  6. The paragraph is now bold and contains a spam with inline CSS.

Because this is quite specific I also attached an animated gif that hopefully shows this issue in a way that's easier to understand.

I can reproduce this issue in TYPO3 6.1.7 and 6.2.2. I also seem to be able to reproduce this issue using any sort of block format.


Files

rte-issue.gif (341 KB) rte-issue.gif Wouter Beeftink, 2014-06-13 17:30

Related issues

Related to TYPO3 Core - Bug #52470: In Chrome RTE inserts weird SPAN tagsClosedStanislas Rolland2013-10-02

Actions
Related to TYPO3 Core - Bug #67348: RTE inserts <span class="line-height: xx"> in ChromeClosed2015-06-08

Actions

Also available in: Atom PDF