Bug #60296

Task executor ignores full framework configuration

Added by Mathias Brodala over 5 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Category:
-
Target version:
Start date:
2014-07-14
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

In the initialization step of the Scheduler task executor, class implementations are registered but only based on config.tx_extbase.objects. Possible overrides through module.tx_<myext>.objects are currently ignored.

This should be changed to respect the full framework configuration instead like what TYPO3\CMS\Extbase\Core\Bootstrap already does since #44796 was fixed.


Related issues

Duplicated by TYPO3 Core - Bug #61995: Extbase: Overwriting objects by TS not working in CommandController? Closed 2014-10-01

Associated revisions

Revision e24ffe5c (diff)
Added by Mathias Brodala about 5 years ago

[BUGFIX] Respect different object mapping for scheduler tasks

Resolves: #60296
Releases: master, 6.2, 6.1
Change-Id: I7bff792b33ffecbe53ac4aee848e6ad16318a538
Reviewed-on: http://review.typo3.org/31618
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Stefan Froemken <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision 92f9daf3 (diff)
Added by Mathias Brodala about 5 years ago

[BUGFIX] Respect different object mapping for scheduler tasks

Resolves: #60296
Releases: master, 6.2, 6.1
Change-Id: I7bff792b33ffecbe53ac4aee848e6ad16318a538
Reviewed-on: http://review.typo3.org/33493
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision 89006b65 (diff)
Added by Mathias Brodala about 5 years ago

[BUGFIX] Respect different object mapping for scheduler tasks

Resolves: #60296
Releases: master, 6.2, 6.1
Change-Id: I7bff792b33ffecbe53ac4aee848e6ad16318a538
Reviewed-on: http://review.typo3.org/33494
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

Revision 0a517b0a (diff)
Added by Wouter Wolters about 5 years ago

[BUGFIX] Fix unit tests for TaskExecutor

Resolves: #60296
Releases: 6.1
Change-Id: Ic4b237a3589a82ef9f870221ef930e0a182e1c85
Reviewed-on: http://review.typo3.org/33496
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>

History

#1 Updated by Markus Klein over 5 years ago

  • Project changed from Extbase MVC Framework to TYPO3 Core
  • Category deleted (Extbase)
  • TYPO3 Version set to 6.2
  • Is Regression set to No

#2 Updated by Mathias Brodala over 5 years ago

Since it somehow does not show up here, here's the related changeset on Gerrit:

https://review.typo3.org/31618/

#3 Updated by Mathias Brodala over 5 years ago

What's the status on this issue?

#4 Updated by Gerrit Code Review about 5 years ago

  • Status changed from New to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31618

#5 Updated by Gerrit Code Review about 5 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/31618

#6 Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33493

#7 Updated by Gerrit Code Review about 5 years ago

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33494

#8 Updated by Mathias Brodala about 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Gerrit Code Review about 5 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-1 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33496

#10 Updated by Wouter Wolters about 5 years ago

  • Status changed from Under Review to Resolved

#11 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF