Bug #62345

Epic #62041: twbs Bootstrap backend, refactor EXT:t3skin and HTML5 output

ElementBrowser output broken

Added by Felix Kopp about 5 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
Start date:
2014-10-20
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The ElementBrowser does not display output at the moment.
Seems to be connected to this->doc->startPage which adds ExtJs styles hiding the html.


Related issues

Related to TYPO3 Core - Task #62038: Deprecate unused/non-unified DocumentTemplate code Closed 2014-10-05

Associated revisions

Revision 5d4cfef9 (diff)
Added by Benni Mack about 5 years ago

[BUGFIX] Make element browser work again

Due to the cleanup of the DocumentTemplate
html variants, the Element Browser did not
work as a <body> tag is now rendered.

The solution is to only fetch the
<html> and <head> part from the
PageRenderer and build the frameset part.

Resolves: #62825
Resolves: #62345
Releases: master
Change-Id: Id267e1e9b79c000f17e52a60901602002c13d45a
Reviewed-on: http://review.typo3.org/33948
Reviewed-by: Stefan Froemken <>
Tested-by: Stefan Froemken <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Steffen Müller about 5 years ago

Regression from http://review.typo3.org/33167
Before that changeset, the element browser works.

#2 Updated by Markus Klein about 5 years ago

  • Target version set to 7.0
  • Is Regression changed from No to Yes

#3 Updated by Gerrit Code Review about 5 years ago

  • Status changed from Accepted to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/33948

#4 Updated by Benni Mack about 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF