Bug #64436

EM isn´t showing modified extensions

Added by Larsen no-lastname-given over 6 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
Start date:
2015-01-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

The new EM from Typo3 6.2 doesn´t show much needed information for us system admins. When a security announcement for an extension is released, I have to check which domains (out of several hundred) use that specific extension and wether is has been modified. If it has been modified, it cannot simply be updated as this might break the website or remove important things that have been added manually before.

This has been very easy in the EM from 4.5, but there seems to be no way of getting this vital information with 6.2.

Several other users want that feature too, see discussion in:
http://forum.typo3.org/index.php/t/203799/
http://forum.typo3.org/index.php/t/200310/

Workaround:
"Check if extension has been modified" is available via https://github.com/xperseguers/t3ext-em_developer but should really be in the core installation like it used to!

#1

Updated by Mathias Schreiber over 6 years ago

  • Target version set to 7.3 (Packages)
#2

Updated by Stefan Holz over 6 years ago

+1

#3

Updated by Benni Mack over 6 years ago

  • Target version changed from 7.3 (Packages) to 7.4 (Backend)
#4

Updated by Nicole Cordes over 6 years ago

  • Status changed from New to Needs Feedback

You can simply install the extension devtools to get a visible icon for changed extensions.

#5

Updated by Larsen no-lastname-given over 6 years ago

I tested this with the phpMyAdmin extension that is installed globally:
- Copied "ext_tables.php" to "ext_tables.php_backup"
- Modifed "ext_tables.php" by adding two empty lines in the middle
- Installed devtools extension

I was then presented with an exclamation mark icon for phpMyAdmin. Though, when I clicked on it, the popup only showed that "ext_tables.php_backup" was added, but not that ""ext_tables.php" had been modified. Therefore, this is no help at the moment.

Also, this really should be core functionality like it used to be.

#6

Updated by Riccardo De Contardi about 6 years ago

  • Status changed from Needs Feedback to Closed

I close this as it is a duplicate of #63898 ,please continue the discussion there.

If you think that this is the wrong decision, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF