Bug #64874

Clicking on directory in link wizard reloads window and deletes all entries the user made before

Added by Christof Hagedorn almost 7 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
-
Start date:
2015-02-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Steps to reproduce:

1. Open RTE.
2. Enter Text
3.Mark Text and klick Link Button in RTE
4. Enter title
5. Select another folder to select a file.

The last steps deletes all entries the user made before.
Its not intuitive that the user has to save before chossing a file.


Related issues

Related to TYPO3 Core - Bug #70844: RTE link wizard: Classes cannot be changed in other than default tabClosed2015-10-19

Actions
#1

Updated by Mathias Schreiber almost 7 years ago

  • Category set to RTE (rtehtmlarea + ckeditor)
#2

Updated by Stephan Großberndt almost 7 years ago

  • Subject changed from Klick on directory in link wizard reloads window and deletes all enries the user made before to Clicking on directory in link wizard reloads window and deletes all entries the user made before
#3

Updated by Stanislas Rolland almost 7 years ago

I am not able to reproduce this issue.

In what browser does it happen?

Any error reported on the JavaScript console?

#4

Updated by Stanislas Rolland almost 7 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Stanislas Rolland
#5

Updated by Riccardo De Contardi over 6 years ago

It is still reproducible in 6.2.12:

steps:

1) open RTE
2) mark a word and click on "insert link" icon
3) go to the tab "File"
4) type something in the field "Title" instead of the default "Initiates file download"
5) select a folder different from the initial one to add a file
6) the title field reverts to "Initiates file download"

#6

Updated by Alexander Opitz over 6 years ago

  • Status changed from Needs Feedback to New
#7

Updated by Riccardo De Contardi over 4 years ago

  • Status changed from New to Closed
  • Assignee deleted (Stanislas Rolland)

This issue is solved in 7.6.x and 8, so I close it.

Test:

1) open RTE
2) mark a word and click on "insert link" icon
3) go to the tab "File"
4) type something in the field "Title" Note that there is no default text
5) select a folder different from the initial one to add a file
6) the title field typed at point 3 remains
7) click on a file to close the modal
8) inspect the text with "toggle text mode" - the title is written

If you think that this is the wrong decision or experience the issue again, please reopen it or open a new issue with a reference to this one. Thank you!

Also available in: Atom PDF