Project

General

Profile

Actions

Bug #64899

closed

Wizard missing in new CEs like Form or Table

Added by Frederic Gaus over 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-02-06
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

In current master the form wizard is not accessible because the button is missing. Steps to reproduce with Form (same is possible with table):

1) Create a new Content Element of type Form
2) Go to tab "Form"
Notice: No button to open wizard

3) Safe the CE
Notice: Wizard button is visible


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #63102: Form Wizard icon not present on freshly created form content elementClosed2014-11-20

Actions
Related to TYPO3 Core - Bug #59466: TCA Manipulation in sysext form ext_tables.php prevents proper TCA/Overrides functionalityClosedAnja Leichsenring2014-06-10

Actions
Actions #1

Updated by Mathias Schreiber over 9 years ago

  • Status changed from New to Accepted
  • Target version changed from 7.1 (Cleanup) to 7.4 (Backend)
  • Sprint Focus deleted (Stabilization Sprint)

I removed the Stabilization Phase because this behavior is there since 3.3.0 ;-)
I agree we should take a look to improve this but it's nothing we broke recently.

Actions #2

Updated by Michael Oehlhof over 9 years ago

Item 63102 describes same problem.

Actions #3

Updated by Susanne Moog almost 9 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #4

Updated by Frans Saris over 8 years ago

  • Sprint Focus set to Stabilization Sprint
Actions #5

Updated by Frans Saris over 8 years ago

This configuration option is preventing the wizard from showing:

$GLOBALS['TCA']['tt_content']['columns']['bodytext']['config']['wizards']['forms'] = array(
    'notNewRecords' => 1,
Actions #6

Updated by Frans Saris over 8 years ago

  • Status changed from Accepted to Closed

The wizards need the uid of the CE. So this only works after when the CE has been saved.

Actions

Also available in: Atom PDF