Bug #65480

TYPO3 6.2.10 Flexform: Values of section elements are not displayed

Added by Christoph Lehmann over 7 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
-
Target version:
Start date:
2015-03-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
6.2
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:
Stabilization Sprint

Description

I updated from 6.2.9 to 6.2.10 and the flexform values are not shown.

My Flexform with section:

<T3DataStructure>
    <meta>
        <langDisable>1</langDisable>
    </meta>
    <sheets>
        <sDEF>
            <ROOT>
                <TCEforms>
                    <sheetTitle>Event</sheetTitle>
                </TCEforms>
                <type>array</type>
                <el>
                    <contributors_otherContainer>
                        <title>Weitere Mitwirkende</title>
                        <section>1</section>
                        <type>array</type>
                        <el>
                            <contributor_other>
                                <type>array</type>
                                <title>Mitwirkende</title>
                                <el>
                                    <field1>
                                        <TCEforms type="array">
                                            <label>Name</label>
                                            <config>
                                                <type>input</type>
                                                <size>20</size>
                                                <max>60</max>
                                                <eval>trim</eval>
                                            </config>
                                        </TCEforms>
                                    </field1>
                                </el>
                            </contributor_other>
                        </el>
                    </contributors_otherContainer>
                </el>
            </ROOT>
        </sDEF>
    </sheets>
</T3DataStructure>

This is stored in the db... seems correct to me.

<?xml version="1.0" encoding="utf-8" standalone="yes" ?>
<T3FlexForms>
    <data>
        <sheet index="sDEF">
            <language index="lDEF">
                <field index="contributors_otherContainer">
                    <el index="el">
                        <section index="1">
                            <itemType index="contributor_other">
                                <el>
                                    <field index="field1">
                                        <value index="vDEF">Buja</value>
                                    </field>
                                </el>
                            </itemType>
                            <itemType index="_TOGGLE">0</itemType>
                        </section>
                    </el>
                </field>
            </language>
        </sheet>
    </data>
</T3FlexForms>

After saving the value of field1 is not shown in the Backend, but the empty section element (screenshot)


Files

flexform empty.png (18.6 KB) flexform empty.png Christoph Lehmann, 2015-03-03 13:59

Related issues

Related to TYPO3 Core - Bug #57824: Palette fields are not wrapped, because --linebreak-- values are removedClosed2014-04-11

Actions
Related to TYPO3 Core - Bug #67259: addToAllTCAtypes does not work with replace positionClosedMarkus Klein2015-06-03

Actions
#1

Updated by Stephan Großberndt over 7 years ago

  • Is Regression changed from No to Yes
#2

Updated by Stephan Großberndt over 7 years ago

  • Target version set to next-patchlevel
#3

Updated by Christoph Lehmann over 7 years ago

The problem seems to be somewhere in the backend javascript since the saved value is visible in a hidden field...

#4

Updated by Kai Möller over 7 years ago

The error is caused by this change 7c58aca7b4031b153df49c98bda56b881b0fe950.
When the commit is reversed it works properly.

The Flexform is used in TCA configuration like this:

$TCA['tx_cal_event']['types'] = array(
    // Default event
    '0' => array('showitem' =>
        '--div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.general_sheet,type, title;;1;;,--palette--;LLL:EXT:cal/locallang_db.php:tx_cal_event.start;5,--palette--;LLL:EXT:cal/locallang_db.php:tx_cal_event.end;6,calendar_id,category_id,' . ($useTeaser ? 'teaser;;;richtext:rte_transform[flag=rte_enabled|mode=ts_css],' : '') . 'description;;5;richtext:rte_transform[flag=rte_enabled|mode=ts_css],
        --div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.recurrence_sheet, freq;;2;;, byday, bymonthday, bymonth, rdate_type;;7;;, deviation, exception_cnt,
        --div--;Veranstaltungsort,myextension_cal_location_contact_uid,location,location_link,
        --div--;Veranstalter,myextension_cal_organizer_contact_uid,organizer,organizer_link,
        --div--;Leitung,myextension_cal_director_contact_uid,myextension_cal_director_contact_alt,
        --div--;Eigentümer,myextension_cal_owner_contact_uid,
        --div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.files_sheet,myextension_cal_fal_images,myextension_cal_fal_attachments,
        --div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.other_sheet, monitor_cnt, shared_user_cnt'
    ),
    // Concert
    '5' => array('showitem' =>
        '--div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.general_sheet,type, title;;1;;,--palette--;LLL:EXT:cal/locallang_db.php:tx_cal_event.start;5,--palette--;LLL:EXT:cal/locallang_db.php:tx_cal_event.end;6,calendar_id,category_id,' . ($useTeaser ? 'teaser;;;richtext:rte_transform[flag=rte_enabled|mode=ts_css],' : '') . 'description;;5;richtext:rte_transform[flag=rte_enabled|mode=ts_css],
        --div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.recurrence_sheet, freq;;2;;, byday, bymonthday, bymonth, rdate_type;;7;;, deviation, exception_cnt,
        --div--;Konzertdetails,myextension_cal_additional_fields,
        --div--;Veranstaltungsort,myextension_cal_location_contact_uid,location,location_link,
        --div--;Veranstalter,myextension_cal_organizer_contact_uid,organizer,organizer_link,
        --div--;Leitung,myextension_cal_director_contact_uid,myextension_cal_director_contact_alt,
        --div--;Eigentümer,myextension_cal_owner_contact_uid,
        --div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.files_sheet,myextension_cal_fal_images,myextension_cal_fal_attachments,
        --div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.other_sheet, monitor_cnt, shared_user_cnt'
    ),
    // Church service (Gottesdienst)
    '6' => array('showitem' =>
        '--div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.general_sheet,type, title;;1;;,--palette--;LLL:EXT:cal/locallang_db.php:tx_cal_event.start;5,--palette--;LLL:EXT:cal/locallang_db.php:tx_cal_event.end;6,calendar_id,category_id,' . ($useTeaser ? 'teaser;;;richtext:rte_transform[flag=rte_enabled|mode=ts_css],' : '') . 'description;;5;richtext:rte_transform[flag=rte_enabled|mode=ts_css],
        --div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.recurrence_sheet, freq;;2;;, byday, bymonthday, bymonth, rdate_type;;7;;, deviation, exception_cnt,
        --div--;Gottesdienstdetails,myextension_cal_additional_fields,
        --div--;Veranstaltungsort,myextension_cal_location_contact_uid,location,location_link,
        --div--;Veranstalter,myextension_cal_organizer_contact_uid,organizer,organizer_link,
        --div--;Leitung,myextension_cal_director_contact_uid,myextension_cal_director_contact_alt,
        --div--;Eigentümer,myextension_cal_owner_contact_uid,
        --div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.files_sheet,myextension_cal_fal_images,myextension_cal_fal_attachments,
        --div--;LLL:EXT:cal/locallang_db.xml:tx_cal_event.other_sheet, monitor_cnt, shared_user_cnt'
    )
);

$additionalCalColumns = array(
    ...
    'myField' => array(
        'config' => array(
            'type' => 'flex',
            'ds_pointerField' => 'type',
            'ds' => array(
                '5' => 'FILE:EXT:my_extension/Configuration/FlexForms/FlexformOne.xml',
                '6' => 'FILE:EXT:my_extension/Configuration/FlexForms/FlexformTwo.xml',
            ),
        )
    ),
    ...
)

#5

Updated by Markus Klein over 7 years ago

  • Description updated (diff)
#6

Updated by Markus Klein over 7 years ago

Can you please show us the exact API calls use make.
Of special interest: addFieldsToPalette(), addToAllTCAtypes()

#7

Updated by Nicole Cordes over 7 years ago

  • Assignee set to Nicole Cordes
#8

Updated by Gerrit Code Review over 7 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38528

#9

Updated by Gerrit Code Review over 7 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38528

#10

Updated by Gerrit Code Review over 7 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38528

#11

Updated by Gerrit Code Review over 7 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38528

#12

Updated by Gerrit Code Review over 7 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38528

#13

Updated by Xavier Perseguers over 7 years ago

  • Target version changed from next-patchlevel to 6.2.12
  • Sprint Focus set to Stabilization Sprint
#14

Updated by Gerrit Code Review over 7 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/38610

#15

Updated by Nicole Cordes over 7 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#16

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF