Bug #65636

Metadata not editable for a readonly file storage

Added by Bernd Wilke over 4 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
File Abstraction Layer (FAL)
Target version:
-
Start date:
2015-03-10
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

this might be correct sometimes1, but I have the usage:
readonly image-server inside TYPO3 (images are stored via FTP by graphic department), as this is a linux mount, nobody having access to the TYPO3 server can modify anything on that server.

But editors should be able to set default-values for alt, title, description, ... for the images, so they could build up a library of files with metadata.
Now they only can set these data in a usage overwriting the empty default values, which can lead to incoherent data.

as the metadata is stored in the database it is independent of writablity of the file-storage.

[1] possible feature:
the file-storage record may hold another flag, whether editors should be able to set metadata globaly so the file-storage is readonly else.


Related issues

Related to TYPO3 Core - Bug #87054: invalid file name of RST Closed 2018-12-01
Duplicated by TYPO3 Core - Task #86317: [BUGFIX] Make meta data editable for non-writable storages Closed 2018-09-19
Precedes TYPO3 Core - Feature #87013: Add editMetaData a permission for users, storages, filemounts New 2015-03-11 2015-03-11

Associated revisions

Revision c3fef10f (diff)
Added by Nicole Cordes 9 months ago

[BUGFIX] Make meta data editable for non-writable storages

Decouple check for writable files/storage from permission
to edit meta data. Permission to edit meta data is now
only denied when users have only access to the file
via a readonly file mount.

Resolves: #65636
Resolves: #66507
Releases: master, 8.7
Change-Id: I25a0fbc9cf761898dbdb95dec1d3d39bb2f4b7fd
Reviewed-on: https://review.typo3.org/42874
Tested-by: TYPO3com <>
Reviewed-by: Oliver Klee <>
Reviewed-by: Joerg Kummer <>
Reviewed-by: Josef Glatz <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision f9c6e31d (diff)
Added by Nicole Cordes 9 months ago

[BUGFIX] Make meta data editable for non-writable storages

Decouple check for writable files/storage from permission
to edit meta data. Permission to edit meta data is now
only denied when users have only access to the file
via a readonly file mount.

Resolves: #65636
Resolves: #66507
Releases: master, 8.7
Change-Id: I25a0fbc9cf761898dbdb95dec1d3d39bb2f4b7fd
Reviewed-on: https://review.typo3.org/58978
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision 0ba69478 (diff)
Added by Benni Mack 9 months ago

[BUGFIX] Rename invalid file name of RST

Due to a bug within Gerrit's editing interface, a file got renamed with a "\t"
filename at the end.

Resolves: #87054
Related: #65636
Releases: 8.7
Change-Id: Id9440309ef48000465e927fabe49a3d4a851e7ee
Reviewed-on: https://review.typo3.org/59007
Reviewed-by: Oliver Klee <>
Tested-by: TYPO3com <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Riccardo De Contardi about 4 years ago

still valid for 7.5-dev (latest master)

#2 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42874

#3 Updated by Gerrit Code Review almost 4 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42874

#4 Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/42874

#5 Updated by Nicole Cordes about 1 year ago

  • Status changed from Under Review to Accepted

#6 Updated by Gerrit Code Review 11 months ago

  • Status changed from Accepted to Under Review

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/42874

#7 Updated by Gerrit Code Review 11 months ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58335

#8 Updated by Anja Leichsenring 11 months ago

  • Duplicated by Task #86317: [BUGFIX] Make meta data editable for non-writable storages added

#9 Updated by Gerrit Code Review 11 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/42874

#10 Updated by Gerrit Code Review 10 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/42874

#11 Updated by Gerrit Code Review 10 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/42874

#12 Updated by Gerrit Code Review 10 months ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/42874

#13 Updated by Helmut Hummel 9 months ago

  • Precedes Feature #87013: Add editMetaData a permission for users, storages, filemounts added

#14 Updated by Gerrit Code Review 9 months ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58978

#15 Updated by Nicole Cordes 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#16 Updated by Gerrit Code Review 9 months ago

  • Status changed from Resolved to Under Review

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58978

#17 Updated by Nicole Cordes 9 months ago

  • Status changed from Under Review to Resolved

#18 Updated by Benni Mack 9 months ago

  • Related to Bug #87054: invalid file name of RST added

#19 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF