Bug #66169

Empty grid list in frontend workspace preview

Added by Leslaw Pazdzior over 4 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Workspaces
Target version:
-
Start date:
2015-03-31
Due date:
% Done:

100%

TYPO3 Version:
6.2
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

When you go to preview of page in any draft workspace you can see page preview, but List view is empty (see attachment).
I tried on 2 different installations (with the newest version 6.2.12-dev, but error is also in older versions like 6.2.9).

scrn_002.png View (37.6 KB) Leslaw Pazdzior, 2015-03-31 08:52

pic1411.png View (326 KB) Jose Antonio Guerra, 2015-04-14 18:46

screen.PNG View (96.1 KB) Mansoor Ahmad, 2015-04-22 12:26

Associated revisions

Revision a22fb180 (diff)
Added by Oliver Hader over 3 years ago

[BUGFIX] Empty grid list in frontend workspace preview

The grid list of the frontend workspace preview stayed empty due to
several JavaScript issues. First one is a CORS thingy with local
document.domain values being set and for the list IFRAME being set
too late (and thus running into CORS error). Besides that the tabs
component is only available in the backend workspace module and
leads to another error if expected and used in the frontend preview.

Resolves: #66169
Releases: master, 6.2
Change-Id: I5bf3dd7760c9382527d85e6e7e8e0ad5dca81c05
Reviewed-on: https://review.typo3.org/44307
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

Revision e2713a52 (diff)
Added by Oliver Hader over 3 years ago

[BUGFIX] Empty grid list in frontend workspace preview

The grid list of the frontend workspace preview stayed empty due to
several JavaScript issues. First one is a CORS thingy with local
document.domain values being set and for the list IFRAME being set
too late (and thus running into CORS error). Besides that the tabs
component is only available in the backend workspace module and
leads to another error if expected and used in the frontend preview.

Resolves: #66169
Releases: master, 6.2
Change-Id: I5bf3dd7760c9382527d85e6e7e8e0ad5dca81c05
Reviewed-on: https://review.typo3.org/44305
Reviewed-by: Oliver Hader <>
Tested-by: Oliver Hader <>

History

#1 Updated by Jose Antonio Guerra over 4 years ago

This is what you get in the JS console:

I tested it on several sites with https and http and even tried to add CORS support but the problem is still there.

#2 Updated by Leslaw Pazdzior over 4 years ago

Thank you, Jose for input! It seems that the same js error exists in version 6.1 too and it doesn't make harm.

So I went to bit different direction, and it seems that ajax that supposes to give json array with list of content elements and pages gives quite poor set (typo3/ajax.php?ajaxID=ExtDirect::route&namespace=TYPO3.Workspaces). This array is returned by \TYPO3\CMS\Workspaces\ExtDirect\ActionHandler::loadColumnModel and it is taken from (if it's in workspace with number 1) global: $GLOBALS['BE_USER']->uc['moduleData']['Workspaces']['1']['columns'];

Now, I have no idea why this set is so poor.

#3 Updated by Mansoor Ahmad over 4 years ago

Error is also in 6.2.12! Any Solutions?

#4 Updated by Riccardo De Contardi almost 4 years ago

still an issue in both 6.2.15 and 7.5-dev (latest master)

#5 Updated by Oliver Hader almost 4 years ago

  • Status changed from New to Accepted

#6 Updated by Oliver Hader almost 4 years ago

  • Subject changed from Empty List view on draft preview to Empty grid list in frontend workspace preview

#7 Updated by Gerrit Code Review almost 4 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44305

#8 Updated by Gerrit Code Review almost 4 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44306

#9 Updated by Gerrit Code Review almost 4 years ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44307

#10 Updated by Oliver Hader almost 4 years ago

  • Assignee set to Oliver Hader

Please test and review the recent patches and put your vote on review.typo3.org. Thx

#11 Updated by Mathias Schreiber almost 4 years ago

  • Target version deleted (next-patchlevel)

#12 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/44307

#13 Updated by Oliver Hader over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Benni Mack 11 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF