Bug #66647

Not all signals are dispatched with fully qualified class name

Added by Mathias Brodala about 6 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Must have
Category:
Code Cleanup
Start date:
2015-04-29
Due date:
% Done:

50%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
easy
Is Regression:
No
Sprint Focus:

Description

Some signals are dispatched via __CLASS__ which will change in case the class is moved or renamed.

In all of these cases \Vendor\Package\Class::class should be used instead to ensure constant names. This must be a fully qualified class name, Class::class does not suffice since that will change too in case of move or rename.

#1

Updated by Gerrit Code Review about 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39053

#2

Updated by Benni Mack almost 6 years ago

  • Target version changed from 7.3 (Packages) to 7.4 (Backend)
#3

Updated by Susanne Moog almost 6 years ago

  • Target version changed from 7.4 (Backend) to 7.5
#4

Updated by Benni Mack over 5 years ago

  • Target version changed from 7.5 to 7 LTS
#5

Updated by Jigal van Hemert over 5 years ago

  • Status changed from Under Review to New
#6

Updated by Riccardo De Contardi over 5 years ago

  • Target version changed from 7 LTS to Candidate for Major Version
#7

Updated by Mathias Brodala about 1 year ago

  • Status changed from New to Closed

TYPO3 moves to events so this will become obsolete.

Also available in: Atom PDF