Bug #66704

The CSRF protection token for the requested module is missing or invalid - template tab in backend

Added by Mateusz Wojtuła about 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
Start date:
2015-05-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Hi,
I got the following error with the newest version of TYPO3 (7.3-dev) when I click in template tab on "Edit the whole template record":

Uncaught TYPO3 Exception
#1417988921: The CSRF protection token for the requested module is missing or invalid (More information)

TYPO3\CMS\Core\Exception thrown in file
/var/www/matw/typo3_src/typo3/sysext/backend/Classes/BackendModuleRequestHandler.php in line 62.

2 TYPO3\CMS\Backend\BackendModuleRequestHandler::handleRequest()

/var/www/matw/typo3_src/typo3/sysext/core/Classes/Core/Bootstrap.php:
00189:   $this->registerRequestHandlers();
00190:   $requestHandler = $this->resolveRequestHandler();
00191:   $requestHandler->handleRequest();
00192:   return $this;
00193:  }

1 TYPO3\CMS\Core\Core\Bootstrap::run("typo3/")

/var/www/matw/typo3_src/typo3/mod.php:
00022: define('TYPO3_MODE', 'BE');
00023: require __DIR__ . '/sysext/core/Classes/Core/Bootstrap.php';
00024: \TYPO3\CMS\Core\Core\Bootstrap::getInstance()->run('typo3/')->shutdown();

When I refresh site I have error message "Validating the security token of this form has failed. Please reload the form and submit it again.".

I attach print screen with error and application information.

Best regards
Mateusz


Files

error-and-environment.png (71.9 KB) error-and-environment.png Mateusz Wojtuła, 2015-05-01 14:58

Related issues

Related to TYPO3 Core - Bug #69296: Error when adding first new page after fresh installClosed2015-08-24

Actions
#2

Updated by Riccardo De Contardi almost 6 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mateusz Wojtuła

Hi Mateusz,
I am not able to reproduce this issue on TYPO3 7.4-dev (the latest master); can you confirm? could this be closed?

Thank you!

#3

Updated by d bart almost 6 years ago

I get this error message in 7.3.1.

Fresh install from typo3_src-7.3.1.tar.gz. When I want to add a new page I get this error.

"The CSRF protection token for the requested module is missing or invalid"

Server is Linux, Debian 8, PHP 5.6.7

#4

Updated by d bart almost 6 years ago

I get the same error in 7.4 commit 2ec24139462

Reproduce:

1. clone from https://github.com/TYPO3/TYPO3.CMS.git
2. run composer install
3. setup is workin, backend running
4. click on "New TYPO3 site", click on "New"

----> error

Server is Linux, Debian 8, PHP 5.6.7, running in virtualBox

#5

Updated by Thomas Mayer almost 6 years ago

I filed issue #69296 for the "New" button issue of d_bart. This is different from the original reproduction steps.

#6

Updated by Thomas Mayer almost 6 years ago

moved to #69296

#7

Updated by Thomas Mayer almost 6 years ago

I also can't reproduce it against 7.4.0 with original reproduction steps reported by Mateusz:

  • create page
  • click Template, choose a page
  • dropdown: Info/Modify
  • "Edit the whole template record"

When, instead, there is no page in the page tree, the dropdown "Info/Modify" is not shown and the user cannot provoce the error that way.

====

Anyways, I rarely and unexpectedly noticed "CSRF protection token" errors, at least when testing with empty page tree. Maybe Mateusz had the same problem?

As far as I'm concerned, this issue can be closed (can't reproduce).

#8

Updated by Alexander Opitz almost 6 years ago

  • Category set to Backend User Interface
  • Assignee deleted (Mateusz Wojtuła)
  • Target version set to 7.5
#9

Updated by Roman Teitge almost 6 years ago

Hi there,

I got in 7.4.0 the same error calling different Modules:

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1417988921: The CSRF protection token for the requested module is missing or invalid | TYPO3\CMS\Core\Exception thrown in file ../typo3_src-7.4.0/typo3/sysext/backend/Classes/Http/BackendModuleRequestHandler.php in line 76.

Linux 2.6.32.53-grsec-pvops-xen-x64
PHP 5.6.0
Apache 2.4.10
MySQL 5.6.19

#10

Updated by Alexander Opitz almost 6 years ago

  • Status changed from Needs Feedback to New
#11

Updated by Ivano Luberti almost 6 years ago

Same issue on a newly created 7.4.0 instance on amazon.
Just created from the marketplace
Logged in as admin in the backend.
Right click on the root chosed "new" and got message error

"The CSRF protection token for the requested module is missing or invalid"

Then clicked on the root and got

"Validating the security token of this form has failed. Please reload the form and submit it again."

Install tool doesn't give any advice

Info popup on the right next to the user avata says system is fully operational

Tried to logout and login but got the same error.

#12

Updated by Ivano Luberti almost 6 years ago

Forgot to say that on friday I did the same thing on another instance without any issue and, for example installed introduction package.
So now I have a clean installation operational, with the issue.
If someone wants to take advantage of it...


Correction of the above statement: the issue disappears after installing introduction package.

I have created a third TYP3 amazon instance and recreated the bug

#13

Updated by Tobias H. almost 6 years ago

I can confirm this bug. It happens only one time per day. I have to remove the get paramter from the backend url, after that i am logged in.

#14

Updated by prodigy7 de over 5 years ago

  • Target version changed from 7.5 to 7.4 (Backend)

Same error here with 7.4. Please fix asap!

#15

Updated by Stephan Großberndt over 5 years ago

  • Target version changed from 7.4 (Backend) to 7 LTS
#16

Updated by Mathias Schreiber over 5 years ago

  • Status changed from New to Resolved

fixed on master

#17

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF