Bug #67272

initializeObject() not called for Extbase Domain Model

Added by Morton Jonuschat over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extbase
Target version:
Start date:
2015-06-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Given a controller which does the following in listAction():

$records = $this->modelRepository->findAll();

When accessing the Models in the QueryResult the initializeObject() method is not being called (and __construct() neither, but AFAIK this is by design).

Instantiating a model using the objectManager works as expected, initializeObject() is being called after DI.

$this->objectManager->get(Model::class);

Tested on 7.3-dev@8e13d36


Related issues

Related to TYPO3 Core - Bug #67274: initializeObject() called before dependency injectionClosed2015-06-03

Actions
Related to TYPO3 Core - Bug #66473: Cannot create object implementing Serializable on PHP 5.6ClosedMathias Brodala2015-04-17

Actions
Related to TYPO3 Core - Bug #67407: Improve object creation testsClosed2015-06-11

Actions
Related to TYPO3 Core - Bug #67408: Nail down php 5.6 instantiation issues in testsClosed2015-06-11

Actions
#1

Updated by Morton Jonuschat over 6 years ago

  • Target version set to 6.2.13

Bug also occurs on 6.2.13-dev

#2

Updated by Gerrit Code Review over 6 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39914

#3

Updated by Gerrit Code Review over 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39914

#4

Updated by Gerrit Code Review over 6 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39914

#5

Updated by Xavier Perseguers over 6 years ago

  • Sprint Focus set to Stabilization Sprint
#6

Updated by Gerrit Code Review over 6 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/39914

#7

Updated by Morton Jonuschat over 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#8

Updated by Gerrit Code Review over 6 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40056

#9

Updated by Gerrit Code Review over 6 years ago

Patch set 1 for branch TYPO3_6-2 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/40133

#10

Updated by Helmut Hummel over 6 years ago

This issue is caused by #66473 when using PHP versions where doctrine/intantiator does not unserilize an empty object

#11

Updated by Alexander Opitz over 6 years ago

  • Status changed from Under Review to Closed

Fixed in master for 7, #66473 was reverted for 6.2 so this can be closed.

Also available in: Atom PDF