Bug #67528

Copying a large set of high-res images to clipboard crashes server

Added by Philipp Gampe over 5 years ago. Updated 29 days ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2015-06-16
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
crash,files,images,thumbnails,clipboard
Complexity:
medium
Is Regression:
Yes
Sprint Focus:

Description

Since 47fa57382d7a727f46126e499e82281784cae18a (https://review.typo3.org/#/c/40307/) thumbnails are show by default in the clipboard.
This crashes the server (the PHP process) if you copy many images (default 40) with high-resolution into the clipboard without having display thumbnails set.


Related issues

Related to TYPO3 Core - Epic #83669: Improve file list / file browserNew2009-06-03

Actions
Related to TYPO3 Core - Epic #90676: Clipboard related bugs and featuresAccepted2020-03-07

Actions
#1

Updated by Riccardo De Contardi almost 5 years ago

  • Category set to Performance
#2

Updated by Riccardo De Contardi almost 3 years ago

  • Related to Epic #83669: Improve file list / file browser added
#3

Updated by Christian Eßl 9 months ago

  • Related to Epic #90676: Clipboard related bugs and features added
#4

Updated by Benni Mack 7 months ago

  • Status changed from New to Needs Feedback

Hey Philipp,

crashing would mean - a "memory_limit" issue? Can you add some more details (e.g. attach such an image, memory limit and max_execution_time of the server, PHP version)?

sorry for the late reply.

#5

Updated by Sybille Peters 29 days ago

  • Category changed from Performance to Backend API
  • Status changed from Needs Feedback to Closed
  • Tags set to crash,files,images,thumbnails,clipboard

I could not reproduce this. Used:

System

  • TYPO3 11-dev (master)
  • memory_limit = 256M
  • max_execution_time = 240
  • PHP 7.4

Reproduce

  1. Uploaded several files of resolution 1920x1080.
  2. Switched off thumbnail preview in filelist
  3. removed all processed files via Maintenance > Remove Temporary Assets
  4. copied 40 files to clipboard

Seems to work fine. Copying 40 more to clipboard worked too.

I am closing. Please reopen with more information about error (exception message and stacktrace, TYPO3 version, php.ini settings, sample image etc.) if problem still occurs.

Also available in: Atom PDF