Bug #68486

Elementbrowser links to wrong tab

Added by Stefan Froemken almost 6 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Backend User Interface
Target version:
Start date:
2015-07-23
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Hello,

following lines in an extension

'teaser_image' => array (
    'exclude' => 1,
    'label' => 'LLL:EXT:blabla/Resources/Private/Language/locallang_db.xlf:tx_blabla_article.teaser_image',
    'config' => array (
        'type' => 'group',
        'internal_type' => 'file',
        'allowed' => $GLOBALS['TYPO3_CONF_VARS']['GFX']['imagefile_ext'],
        'max_size' => 500,
        'uploadfolder' => 'uploads/blabla',
        'show_thumbs' => 1,
        'size' => 1,
        'minitems' => 0,
        'maxitems' => 1,
    )
),

If you click on "choose file" the element browser starts with selected tab "File". But if you click on the little icon just in front of fileadmin, the element browser switches to tab page (See ScreenShot)


Files

TYPO3_Element_Browser.jpg (85.4 KB) TYPO3_Element_Browser.jpg Stefan Froemken, 2015-07-23 13:46
linkerror.png (404 KB) linkerror.png Jesper Mathiasen, 2015-07-23 16:14
linkerror_output.png (239 KB) linkerror_output.png Jesper Mathiasen, 2015-07-23 16:14

Related issues

Related to TYPO3 Core - Bug #68018: Rework folder trees based on CSS onlyClosedBenni Mack2015-07-09

Actions
#1

Updated by Jesper Mathiasen almost 6 years ago

Not sure if this is the same bug, but when using the element browser to choose a file and attempting to expand a folder, a 500 error is returned when the ajax call to expand happens.

#2

Updated by Susanne Moog almost 6 years ago

Some more info:
  • I can't reproduce the 500 error
  • I can reproduce the behavior mentioned by Stefan by using the normal link browser -> file -> little arrow in front of root level folder (fileadmin) -> results in landing on page
  • Additionally when opening and closing nodes I get a JavaScript error: Uncaught TypeError: Cannot read property 'navFrameHighlightedID' of undefined
#3

Updated by Markus Klein almost 6 years ago

There is something totally wrong.

TYPO3_Element_Browser.jpg:

Why is there a "remove link" button?
Why are there tabs for records at all, if this field is about files?

#4

Updated by Markus Klein almost 6 years ago

  • Assignee set to Markus Klein
  • Priority changed from Should have to Must have
#5

Updated by Markus Klein almost 6 years ago

Core-internal usage of this TCA configuration is fe_users.image. Can be tested there.

#6

Updated by Markus Klein almost 6 years ago

First issue: jquery is not loaded in the popup.
/master/typo3/sysext/core/Resources/Public/JavaScript/Contrib/jquery.js?bust=1438000762
This path does not exist

#7

Updated by Markus Klein almost 6 years ago

The jQuery issue is fixed with #68555

#8

Updated by Markus Klein almost 6 years ago

  • Status changed from New to In Progress
#9

Updated by Markus Klein almost 6 years ago

Breaking code introduced with #68018

#10

Updated by Markus Klein almost 6 years ago

Maybe not only the aforementioned issue is to blame, but the whole implementation for tree roots

#11

Updated by Gerrit Code Review almost 6 years ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41989

#12

Updated by Gerrit Code Review almost 6 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/41989

#13

Updated by Markus Klein almost 6 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#14

Updated by Riccardo De Contardi over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF