Bug #69047

Returned value from "form field wizard" in flexform is not stored in database

Added by Armin Vieweg almost 4 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-08-14
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When using a wizard in Flexform like the wizard_element_browser the value from the popup will be returned correctly and visible in the input field which got the wizard. But when saving the record, the value is gone.

This is such a wizard configuration:

<config>
        <type>input</type>
        <size>50</size>
        <max>256</max>
        <eval>trim</eval>
        <softref>typolink</softref>
        <wizards type="array">
                <link type="array">
                        <type>popup</type>
                        <title>Link</title>
                        <icon>EXT:backend/Resources/Public/Images/FormFieldWizard/wizard_link.gif</icon>
                        <module type="array">
                                <name>wizard_element_browser</name>
                                <urlParameters type="array">
                                        <mode>wizard</mode>
                                </urlParameters>
                        </module>
                        <JSopenParams>width=800,height=600,status=0,menubar=0,scrollbars=1</JSopenParams>
                </link>
        </wizards>
</config>

The reason why the value is not stored in database properly, is that there are two form fields are existing:
  1. data[tt_content][NEW123...][pi_flexform][data][sheet0][lDEF][settings.link][vDEF]_hr
  2. data[tt_content][NEW123...][pi_flexform][data][sheet0][lDEF][settings.link][vDEF]

But just the first one got the value from the wizard. The second field remains empty (or got the original value), but this is the field which will be transfered to server.

When editing the input manually, using the keyboard, it works and both form fields got the entered value.


Related issues

Related to TYPO3 Core - Bug #75943: Returned value from "form field wizard" in flexform is not stored in database, when compatibility6 is installed Closed 2016-04-27
Duplicated by Dynamic Content Elements (DCE) - Bug #69373: Link values filled in with the Link Wizard are not kept after saving Rejected 2015-08-27
Duplicated by TYPO3 Core - Bug #70602: Page link wizard does not save selected page uid Closed 2015-10-12

Associated revisions

Revision 22ee3c1f (diff)
Added by Frank Naegler over 3 years ago

[BUGFIX] "form field wizard" in flexform not saved

This patch fix a bug for wizards in flex forms.

Resolves: #69047
Releases: master
Change-Id: I2bf8f79729c2d31166c77a1a85b3e77cf03828a0
Reviewed-on: http://review.typo3.org/43741
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Armin Vieweg almost 4 years ago

Tested in TYPO3 7.4.0

#2 Updated by Frank Naegler almost 4 years ago

  • Category set to FormEngine aka TCEforms
  • Status changed from New to Accepted
  • Assignee set to Frank Naegler
  • Target version set to 7.5
  • Sprint Focus set to Stabilization Sprint

#3 Updated by Benni Mack over 3 years ago

  • Target version changed from 7.5 to 7 LTS
  • Sprint Focus deleted (Stabilization Sprint)

#4 Updated by Gerrit Code Review over 3 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43741

#5 Updated by Frank Naegler over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Riccardo De Contardi over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF