Project

General

Profile

Actions

Bug #69195

closed

EXT:form - Error if old mailform option is called

Added by Konstantin Salakhutdinov almost 9 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
Start date:
2015-08-19
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

When using the old mailform option and having useDefaultContentObject set in typoscript breaks the website if ext:compatibility6 is not installed.

if ($typoScriptObjectName === 'FORM' && !empty($typoScript['useDefaultContentObject'])) {
$content = $contentObject->getContentObject($typoScriptObjectName)->render($typoScript); <----- breaks here
} elseif ($typoScriptObjectName === 'FORM') {

Actions #1

Updated by Wouter Wolters almost 9 years ago

  • Status changed from New to Needs Feedback

I'm sorry but with this description we can't find out what is going on.
Please give us more information about the form itself etc.

A white screen means a PHP error that should be logged.
Can you at least try to enable the development preset in the Install Tool and check the error logs again.

Actions #2

Updated by Konstantin Salakhutdinov almost 9 years ago

Sorry, initiated developer mode in install tool and see hundreds of Notices lines and a last line that is like this:

Fatal error: Call to a member function render() on a non-object in /home/k/konstantin/typo3_src-7.4.0/typo3/sysext/form/Classes/Controller/FormController.php on line 92

Actions #3

Updated by Wouter Wolters almost 9 years ago

  • Subject changed from Mail Form in Typo3 7.4 leads to white screen to Old mailform option called within ext:form
  • Description updated (diff)
  • Status changed from Needs Feedback to Accepted

You use the old school mailform option from TYPO3. This option has been moved to ext:compatibility6 and will be moved out of the core. This extension needs to be installed to make your website work again.

I will get in contact with a developer if we can make this work without a fatal error, but an nicer error message.

Actions #4

Updated by Wouter Wolters almost 9 years ago

  • Description updated (diff)
Actions #5

Updated by Konstantin Salakhutdinov almost 9 years ago

Ok, but if sysext form is not actual anymore, then why is it still included in Typo3 7.4 ? I think it is more handy than powermail for simple forms, because of easy to use interface.

Actions #6

Updated by Wouter Wolters almost 9 years ago

I think you got me wrong there. ext:form is just working, but your form still uses the earlier form solution of the core. Which is moved to ext:compatibility6.

Check if your TypoScript contains the option "useDefaultContentObject". This calls the old form solution which is located in the compat extension now.

Actions #7

Updated by Konstantin Salakhutdinov almost 9 years ago

Wouter Wolters wrote:

Check if your TypoScript contains the option "useDefaultContentObject". This calls the old form solution which is located in the compat extension now.

Wow. You are definitely right "useDefaultContentObject" is set to 1. I found it in Typo Script Object Browser.
But it is strange. To understand what's the problem I've installed fresh Typo3 7.4 distributive and used only that what it offers. Only extensions that were installed are:
- Builder
- Fluidconent
- Fluidpages
- vhs
- flux

So I can't imaging where did old mailform come from...

Actions #8

Updated by Wouter Wolters almost 9 years ago

Do you include css_styled_content version 6.2 typoscript?

Actions #9

Updated by Konstantin Salakhutdinov almost 9 years ago

Wouter Wolters wrote:

Do you include css_styled_content version 6.2 typoscript?

Yes. But i tried including usual csc and also fluidcontent_core - and still the problem seems to be in using the old type of mailform CE.

Actions #10

Updated by Gerrit Code Review over 8 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43472

Actions #11

Updated by Gerrit Code Review over 8 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43472

Actions #12

Updated by Ralf Zimmermann over 8 years ago

  • Subject changed from Old mailform option called within ext:form to EXT:form - Error if old mailform option is called
Actions #13

Updated by Gerrit Code Review over 8 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43472

Actions #14

Updated by Björn Jacob over 8 years ago

  • Target version changed from 7.4 (Backend) to 7.5
Actions #15

Updated by Benni Mack over 8 years ago

  • Sprint Focus set to Stabilization Sprint
Actions #16

Updated by Ralf Zimmermann over 8 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #17

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF