Bug #69322

File Picker: Changing folder is broken

Added by Sebastian Michaelsen about 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Backend API
Target version:
Start date:
2015-08-26
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
medium
Is Regression:
Yes
Sprint Focus:
Stabilization Sprint

Description

  • Open a record with a FAL relation field (e.g. Image CE)
  • Click "create new relation"
  • In the "File" tab try to select another folder than your current one
    => Instead of selecting the right folder the view jumps to the "Page" tab

http://shots.michaelsen.io/JTyQ (53KB)


Related issues

Related to TYPO3 Core - Task #69276: Remove global usage of SOBE in Tree context Closed 2015-08-24
Related to TYPO3 Core - Bug #71717: Search form don't work in "Select Records" Closed 2015-11-20

Associated revisions

Revision b32b08df (diff)
Added by Markus Klein about 4 years ago

[BUGFIX] Add missing back reference for file trees

The ElementBrowserFolderTreeView class needs a back reference
to the ElementBrowser as well.
This was forgotten in #69276.

Resolves: #69322
Releases: master
Change-Id: I9722b2cc39e927aa32e318551f47ad4abc5a18a6
Reviewed-on: http://review.typo3.org/42883
Reviewed-by: Sebastian Michaelsen <>
Tested-by: Sebastian Michaelsen <>
Reviewed-by: Daniel Maier <>
Tested-by: Daniel Maier <>
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Reviewed-by: Stephan Großberndt <>
Reviewed-by: Wouter Wolters <>
Tested-by: Wouter Wolters <>

History

#1 Updated by Sebastian Michaelsen about 4 years ago

The problem was introduced with this commit: http://review.typo3.org/42847 (Switching to the commit before fixes the problem for me)

#2 Updated by Sebastian Michaelsen about 4 years ago

A note: If you just click the “arrow” to the left of the folder name, the folder structure is loaded correctly
it’s only if you click the name

#3 Updated by Mathias Schreiber about 4 years ago

  • Assignee set to Markus Klein
  • Target version set to 7.5
  • Sprint Focus set to Stabilization Sprint

#4 Updated by Markus Klein about 4 years ago

  • Category set to Backend API
  • Complexity set to medium
  • Is Regression changed from No to Yes

#5 Updated by Gerrit Code Review about 4 years ago

  • Status changed from New to Under Review

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/42883

#6 Updated by Markus Klein about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF