Bug #69750

Story #69617: FormEngine bugs

TCA select tree does not save state

Added by Alexander Stehlik over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2015-09-13
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

TCA select fields with renderMode tree do not save the collapsed state any more.

The reason for this seems to be, that the top.TYPO3.BackendUserSettings.ExtDirect functionality was removed / replaced?

Currently the expanded state seems to be stored with top.TYPO3.Storage.Persistent which does not seem to have any impact.

History

#1 Updated by Mathias Schreiber about 4 years ago

  • Description updated (diff)
  • Parent task set to #69617

#2 Updated by Frank Naegler about 4 years ago

The problem is located in UserSettingsController::addToList which not handle the array correctly. The DB stores the string "Array" instead of a comma list.

#3 Updated by Frank Naegler about 4 years ago

  • Status changed from New to On Hold

currently a new tree logic is work in progress, we will not fix this issue with the current tree implementation.

The problem is not located in UserSettingsController::addToList as expected. If anyone find a simple fix, we can implement it, but at the moment we don't see a simple fix.

#4 Updated by Tymoteusz Motylewski almost 4 years ago

  • Status changed from On Hold to Closed

in version 8 saving of the tree state for categories was dropped.
The usability of this feature was questionable - settings ware saved independently for each record.
So you see the saved state backend user would need to visit the same record again.
Additionally if user clicked "expand all" all nodes ids were saved into session, making the session size grow over time.

Also available in: Atom PDF