Bug #69867

Story #69617: FormEngine bugs

FormEngine doesn't resolve inline records from flexforms correctly

Added by Sebastian Michaelsen about 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-09-16
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
Stabilization Sprint

Description

Since [!!!][TASK] The FormEngine is dead, long live the FormEngine! I get the following Exception when I try to open a content element in the Backend which has inline FAL images in a flexform field:


http://shots.michaelsen.io/KsfC

The problem could also be related to FluidTYPO3 extensions that are installed on my system, but from digging around in the code the problem seems to occur somewhere in InlineRelatedRecordResolver->getRelatedRecords().

Associated revisions

Revision 92814010 (diff)
Added by Christian Kuhn about 4 years ago

[BUGFIX] Inline in flex

Inline elements within flex forms do not differ from "normal" inline
relations on DB side. For inline relation handling it looks like a
direct table to table connection, even if the connect data is
stored within xml.

The resolve logic triggered by the inline process data provider
thus needs table name and uid of the "parent" record to resolve
inline elements correctly.

Change-Id: I06a97221cadb9ac772494f8e8d9045c41a50d305
Resolves: #69867
Releases: master
Reviewed-on: http://review.typo3.org/43482
Reviewed-by: Daniel Goerz <>
Tested-by: Sebastian Michaelsen <>
Reviewed-by: Morton Jonuschat <>
Tested-by: Morton Jonuschat <>
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>

History

#1 Updated by Christian Kuhn about 4 years ago

  • Parent task set to #69617

#2 Updated by Sebastian Michaelsen about 4 years ago

Additional information:
The above screenshot shows an error loading the sys_file_reference with uid 1. But that is not the correct uid but comes from the fact that there is one image referenced from the flexform field. sys_file_reference:1 is deleted in my system which ultimately results in the above exception.

#3 Updated by Mathias Schreiber about 4 years ago

  • Target version set to 7.5
  • Sprint Focus set to Stabilization Sprint

#4 Updated by Gerrit Code Review about 4 years ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43482

#5 Updated by Gerrit Code Review about 4 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43482

#6 Updated by Gerrit Code Review about 4 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43482

#7 Updated by Gerrit Code Review about 4 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at http://review.typo3.org/43482

#8 Updated by Christian Kuhn about 4 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#9 Updated by Riccardo De Contardi about 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF