Project

General

Profile

Actions

Bug #70668

closed

Epic #65814: Make Indexed search extbase plugin shine

Unable to set custom templates paths

Added by Rafal Brzeski almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Indexed Search
Target version:
Start date:
2015-10-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I tried to set custom path to templateRootPath, partialRootPath and layoutRootPath without any luck.
No matter what is inserted in the settings nothing happens, it seems like plugin.tx_indexedsearch.view is completly ignored even in oryginal source.

my example:

SETUP:
plugin.tx_indexedsearch {
    view {
             templateRootPath = fileadmin/private/assets/html/exts/indexed_search/Templates/
             partialRootPath = fileadmin/private/assets/html/exts/indexed_search/Partials/
             layoutRootPath = fileadmin/private/assets/html/exts/indexed_search/Layouts/
    }
}


Files

indexed_search_includes.png (52.6 KB) indexed_search_includes.png Rafal Brzeski, 2015-11-12 12:32

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #72051: indexed_search does not use assigned templatesClosedDaniel Goerz2015-12-03

Actions
Actions #1

Updated by Josef F. Glatz (Old User) almost 9 years ago

  • Status changed from New to Needs Feedback

Hey Rafal,

did you used the "alternative" Extbase Plugin for Indexed Search? It seems like both the old and new way is possible.

Actions #2

Updated by Rafal Brzeski almost 9 years ago

I use new way "Extbase & Fluid based"

Actions #3

Updated by Tymoteusz Motylewski over 8 years ago

  • Parent task set to #65814

Hi RafaƂ,
Have you tried the templateRootPaths (mind the "s" at the end)?
see example here:
https://docs.typo3.org/typo3cms/TyposcriptReference/ContentObjects/Fluidtemplate/Index.html
Do you have indexed search extbase plugin static template included in your main TS record?

Actions #4

Updated by Rafal Brzeski over 8 years ago

Hi Tymoteusz,
I tried your hint but this doesn't work, static template is included

Actions #5

Updated by Rafal Brzeski over 8 years ago

there is a duplicated issue #72051 which is currently under review

Actions #6

Updated by Daniel Goerz over 8 years ago

  • Status changed from Needs Feedback to Closed

Closed as duplicate of #72051. Please continue any discussion there.

Actions

Also available in: Atom PDF