Project

General

Profile

Actions

Bug #70806

closed

Story #69617: FormEngine bugs

Flexform fields respect ACLs but ACLs cannot be set

Added by Christian Brinkert almost 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Should have
Category:
FormEngine aka TCEforms
Target version:
Start date:
2015-10-17
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

I've written a small extension which extends the page properpies with some flexform fields, which will not be shown since TYPO3 7.5.

Since TYPO3 7.5 the flexform fields are hidden for editors in the backend, but adminstrators will see these fields. I think the extension will be OK, because in TYPO3 7.3 and 7.4 with the same installation, same editor permissions and at the same server everythings works fine and the fields will be shown to editors and adminstrators.

For testing purposes I've set all permissions to the editor users in the access list and even all permissions for the pages in the access modul, but without any success.


Files

missing_flexform_fields_in_T3-7.5.png (54.5 KB) missing_flexform_fields_in_T3-7.5.png Christian Brinkert, 2015-10-17 11:09
Actions #1

Updated by Christian Kuhn almost 9 years ago

  • Parent task set to #69617
Actions #2

Updated by Georg Ringer almost 9 years ago

@christian kuhn: can this be related to the flexform issue I had with EXT:news as well?

@christian brinkert: could you test latest master of the core?

Actions #3

Updated by Christian Brinkert almost 9 years ago

@christian kuhn: OK, I've fixed or rather workaround the error with the missing ClassAliasMap - but without any new result.

Tests with the latest TYPO3 7.6dev, master (ef67ca3) leads to the same error or behavior:
  • flexform field will correctly be shown to the administrator
  • but not for editors with less than administrative-privileges
Actions #4

Updated by Christian Brinkert almost 9 years ago

Addendum (probably maters ...):

The extension I wrote based on the old way of extension development, without extbase/fluid. And the extension extends the page properties not the content elements like the tx_news extension by Georg.

BTW, the flexform fields of the news extension are shown for editors in my installation, whatever TYPO3 version I use (7.3, 7.4, 7.5, 7.6dev)

Actions #5

Updated by Mathias Schreiber over 8 years ago

  • Category changed from Backend User Interface to FormEngine aka TCEforms
Actions #6

Updated by Mathias Schreiber over 8 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber

Can't reproduce on master.
Can you please try again or supply the extension (via Slack for example) so I can double check?

Thanks in advance

Actions #7

Updated by Mathias Schreiber over 8 years ago

  • Subject changed from Flexform fields are not shown for editors with limited permissions to Flexform fields respect ACLs but ACLs cannot be set
  • Status changed from Needs Feedback to Accepted

The behavior can be explained pretty easy.
Supplying the value exclude does not make sense since there is no way to assign flexform ACLs to a user/usergroup.
This flaw now became obvious because the new form rendering does not care whether the field has been defined via a flexform or regular TCA.

Quick win:
Simply remove the <exclude>1</exclude> parts from the flexform - they didn't have any impact anyways.

In the long run we will need (or maybe not) to come up with a solution for setting flexform ACLs or ignore field ACLs in flexforms.

Actions #8

Updated by Christian Brinkert over 8 years ago

Remove "excludes" from flexform works like a charm.
I never would have figured out - many, many thanks!

Actions #9

Updated by Mathias Schreiber over 8 years ago

  • Status changed from Accepted to Closed

We will continue in #40342, because we have a UI solution for that

Actions #10

Updated by Christian Kuhn over 8 years ago

  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF