Bug #71568

always_populate_raw_post_data=

Added by Frank Buijze over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-11-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
7.0
Tags:
PHP7
Complexity:
Is Regression:
No
Sprint Focus:

Description

Warning in Install Tool

--
PHP always_populate_raw_post_data is deprecated

always_populate_raw_post_data=
PHP is configured to automatically populate $HTTP_RAW_POST_DATA.
Warning: Expect fatal errors in central parts of the CMS if the value is not changed to:
always_populate_raw_post_data=-1
--

always_populate_raw_post_data switch is not available in PHP 7. Setting this value is impossible, resulting in numerous error and odd behaviour.


Related issues

Is duplicate of TYPO3 Core - Bug #71959: Installation: Resolve correct PHP version from version stringClosedNicole Cordes2015-11-29

Actions
#1

Updated by Wouter Wolters over 5 years ago

  • Status changed from New to Needs Feedback

Which exact PHP7 version are you on? There is a check in the code that should show you the message: "PHP always_populate_raw_post_data is removed as of PHP 7.0 or newer"

#2

Updated by Benni Mack over 5 years ago

This problem will be resolved automatically once 7.0.0 is out (= in 13 days). We check for "7.0.0" and not "7.0.0rc6". I have the same issue and reproduced and fixed it but tended to not fix it due to the really small relevance for the time being.

#3

Updated by Frank Buijze over 5 years ago

OK, that explains. I will wait till PHP 7 is released.

#4

Updated by Marcus Schwemer over 5 years ago

Just upgraded my homebrew php version to 7.0.0 ... the error message is gone.

This ticket can IMHO be closed.

#5

Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (7 LTS)

Closing as duplicate of #71959 .

Also available in: Atom PDF