Bug #71569

FrontendConfigurationManager::overrideSwitchableControllerActionsFromFlexForm does not check if plugin has flexform

Added by Frank Berger about 5 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Extbase
Target version:
Start date:
2015-11-13
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The Situation is as follows:

An Extbase plugin is inserted which has a Flexform configured, with switchable controller actions. The Plugin is saved. Then the editor realises that the wrong plugin was used, and changes list_type (or ctype) to a diffrent Plugin from the same extention, which does NOT have a Flexform configured!

The Situation is now that tt_content.pi_flexform has valid content, which is not used by the configured plugin, which is so far as it always has been.

But, TYPO3\CMS\Extbase\Configuration\FrontendConfigurationManager::overrideSwitchableControllerActionsFromFlexForm will override the Extbase controller and action based on the contents of pi_flexform without checking if the Plugin which is loaded actually is actually using the flexfrom, resulting in an error saying that controller "" has no valid action available.

Ideal solution
TYPO3\CMS\Extbase\Configuration\FrontendConfigurationManager::overrideSwitchableControllerActionsFromFlexForm
checks if plugin has pi_flexform configured, before overriding its contents into the setup.


Related issues

Related to TYPO3 Core - Bug #20493: flexform ds remains even if the plugin changesRejected2009-05-22

Actions
Related to TYPO3 Core - Bug #73630: flexform data is not deleted when changing pluginAccepted2016-02-23

Actions
Related to TYPO3 Core - Feature #88908: Add "migration wizard" when changing CType of content elementsNew2019-08-03

Actions
Related to TYPO3 Core - Epic #88528: Remove switchable controller action functionalityIn Progress2019-06-08

Actions
#1

Updated by Nicole Cordes about 5 years ago

  • Status changed from New to Accepted

It is not enough to check if a flexform is registered. There are even extensions which registers flexforms for e.g. 2 plugins but only one has switchableControllerActions. The problem already occurs in datahandler while saving the settings. There a validation should only store current flexform infomation in the database.

But this is an known problem since a long time and not related to TYPO3 7 LTS.

#2

Updated by Riccardo De Contardi about 1 year ago

  • Related to Bug #73630: flexform data is not deleted when changing plugin added
#3

Updated by Riccardo De Contardi about 1 year ago

  • Related to Feature #88908: Add "migration wizard" when changing CType of content elements added
#4

Updated by Alexander Schnitzler about 1 year ago

  • Related to Epic #88528: Remove switchable controller action functionality added
#5

Updated by Georg Ringer 9 months ago

  • Status changed from Accepted to Closed

with #88528 switchable controller actions have been removed, therefore I am closing this issue.

Also available in: Atom PDF