Bug #20493

flexform ds remains even if the plugin changes

Added by Sebastian Fischer over 11 years ago. Updated over 3 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2009-05-22
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
4.2
PHP Version:
4.3
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Situation:
tt_content used as tt_news Plugin gets changed into some other Plugin. In this case the xml of the tt_news flexform remains in the flexform field and gets additional flexform xml of the new plugin.

Normaly no problem, it could happen, that if you render tt_news in your own plugin, tt_news gets old configurations of the former plugin.

Yes its a solution to delete the tt_content. But not every author is used to it, so it would be better to overwrite the flexform field on plugin change.

(issue imported from #M11170)


Related issues

Related to TYPO3 Core - Bug #71569: FrontendConfigurationManager::overrideSwitchableControllerActionsFromFlexForm does not check if plugin has flexformClosed2015-11-13

Actions
Related to TYPO3 Core - Bug #73630: flexform data is not deleted when changing pluginAccepted2016-02-23

Actions
Related to TYPO3 Core - Feature #76925: Switching from one content type to another should clear fields not usable anymoreNewBenni Mack2016-07-04

Actions
#1

Updated by Alexander Opitz over 7 years ago

  • Status changed from New to Needs Feedback
  • Target version deleted (0)

The issue is very old, does this issue exists in newer versions of TYPO3 CMS (4.5 or 6.1)?

#2

Updated by Sebastian Fischer over 7 years ago

The problem still exists in 4.5 AND in 6.0. So it's still a problem when you change a plugin to another and relay to much on values from flexform. The fields not present in the attached flexform are not removed while changing the plugin or even content type

#3

Updated by Alexander Opitz over 7 years ago

  • Status changed from Needs Feedback to New
#4

Updated by Wouter Wolters over 7 years ago

This one is AFACS related to https://review.typo3.org/#/c/19930/

#5

Updated by Sebastian Fischer over 7 years ago

Its related but not only depending on a check of listType changed but also cType changed. Because the settings are still present even if you switch to a different maybe custom content type.

#6

Updated by Mathias Schreiber almost 6 years ago

  • Status changed from New to Needs Feedback
  • Assignee set to Mathias Schreiber
  • Is Regression set to No

Would you consider this for Flexforms only?
The same principle applies for any type change.
So the value of the field "subheader" remains in the record after switching into a type that does not show the field.

Would you clear all fields not shown?

#7

Updated by Sebastian Fischer almost 6 years ago

In general i would assume that changing the type removes the unwanted data too, but keeping performance in mind i dont know if its such a good idea to process every content element.

Some could argue to do so only on type change and i would be fine with this agrument.

If its an intentional change everything is good, and using the history its possible to restore the removed data too. So in general i would think its a good idea to clean everything that is not needed anymore.

#8

Updated by Alexander Opitz over 5 years ago

  • Status changed from Needs Feedback to New
  • Assignee deleted (Mathias Schreiber)
#9

Updated by Claus Due over 4 years ago

I don't agree.

Changing a record column like the content type or plugin type does not remove any values from other columns of that record. Removing the flexform "columns" therefore wouldn't make sense, at least to me.

See also https://forge.typo3.org/issues/73630

#10

Updated by Wouter Wolters over 3 years ago

  • Status changed from New to Rejected

Closed as duplicate of #73630

Also available in: Atom PDF