Bug #71850

typolink.forceAbsoluteUrl doesn't force absolute url

Added by Sebastian Michaelsen over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
TypoScript
Target version:
Start date:
2015-11-26
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

This is were it broke: https://github.com/TYPO3/TYPO3.CMS/commit/dacd79bc67c814a4f622dc6bd299ceb521aa325f#diff-fb30f860811e026eb162ad4095fa44e4R6692

parse_url() doesn't always return a host. With the weak comparison it matched the empty string.

Should be something like:

if (!isset($urlParts['host']) || $urlParts['host'] === '') {


Related issues

Duplicates TYPO3 Core - Bug #71843: forceAbsoluteUrl has no effect Closed 2015-11-25

History

#1 Updated by Wouter Wolters over 3 years ago

  • Status changed from New to Closed

Duplicate of #71843

Also available in: Atom PDF