Bug #72107

search in pagetree ends in endless loop in case of DB mounts

Added by Webadmin no-lastname-given over 3 years ago. Updated 4 months ago.

Status:
Needs Feedback
Priority:
Must have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2015-12-08
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
5.6
Tags:
Complexity:
hard
Is Regression:
No
Sprint Focus:

Description

We use Typo3 in a multidomain environment. When searching for "Home" as a non-admin-user, the result tree repeats endless. See attached screenshot. The page "Random Header Startseite" is a normal page without any subpages. We don't see any reason why the page tree includes another mountpoint / Website root here.

The problem doesn't exists in 4.5 with the same page structure.

As an admin user, everything is fine.

admin-user.PNG View (45.4 KB) Webadmin no-lastname-given, 2015-12-08 15:21

non-admin-user.PNG View (100 KB) Webadmin no-lastname-given, 2015-12-08 15:21

FilteredPagetreeDubplicateMounts.png View - Filtered pagetree with db mounts 7 LTS (89.5 KB) Jigal van Hemert, 2016-06-20 15:23

filteredPagetreeDuplicateIssue.diff View (908 Bytes) Franz Kugelmann, 2017-05-29 16:04

History

#1 Updated by Morton Jonuschat over 3 years ago

  • Target version deleted (6.2.16)

#2 Updated by Jigal van Hemert about 3 years ago

  • File FilteredPagetreeDubplicateMounts.png View added
  • Subject changed from search in pagetree ends in endless loop for non-admin users to search in pagetree ends in endless loop in case of DB mounts
  • Complexity set to hard

It's also confirmed in 7LTS and it also happens with admin users if they happen to be member of groups that have DB mounts.
The filtered tree seems to repeat after a page that has not subpages.
A slightly different effect can be seen in other cases where the pagetree is repeated in every DB mount.

Both cases can be seen in the screenshot.

#3 Updated by Franz Kugelmann about 2 years ago

I can probably confirm the behaviour in 7.6.17dev.
See attached diff what seems to fix the problem in my installation.
Since i am not familiar at all with pageTree stuff, i am not sure if that is a viable solution.

#4 Updated by Riccardo De Contardi almost 2 years ago

  • TYPO3 Version changed from 6.2 to 7

#5 Updated by Webadmin no-lastname-given about 1 year ago

  • TYPO3 Version changed from 7 to 8

Still in Typo3 8 LTS

#6 Updated by Riccardo De Contardi 4 months ago

  • Status changed from New to Needs Feedback

Is this still reproducible on TYPO3 9.5.5 or higher?

Also available in: Atom PDF