Bug #72164

"absRefPrefix = auto" does not work if PageGenerator is not used

Added by Sascha Egerer about 4 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2015-12-11
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

If a URL is generated in a CLI Task and the PageGenerator is not used the "auto" value of absRefPrefix is not replaced but added to the URL.

I've currently the probelm in the Solr extension that all my URLs a prefixed with "auto" as "auto" is now the default setting.

I would expect that "auto" is always replaced now matter when and where it is used.

Maybe this problem does also happen due to misusage of core api.


Related issues

Related to TYPO3 Core - Bug #77722: absRefPrefix is not applied everywhere New 2016-08-31

History

#1 Updated by Sascha Egerer about 4 years ago

  • Description updated (diff)

May a simple \TYPO3\CMS\Frontend\Page\PageGenerator::pagegenInit() would help. But it is currently only called for FrontEnd requests.

#2 Updated by Mathias Brodala about 4 years ago

Workaround: use absRefPrefix = / if that's the only value you need on all system.

#3 Updated by Sascha Egerer about 4 years ago

Mathias Brodala wrote:

Workaround: use absRefPrefix = / if that's the only value you need on all system.

Yes i already used that but we should fix that ;)

#4 Updated by Jigal van Hemert over 3 years ago

  • Status changed from New to Needs Feedback

The problem is more that EXT:solr tries to build a FE environment (needed for TS for example) and this is not the same as the normal FE context of TYPO3 itself.
If you create URLs and use typolink.forceAbsoluteUrl = 1 the URL's will also be malformed if the scheduler task is run from CLI. Most of the times these URLs will have the path on the file system in them.
This is caused by the fact that several server variables that are used by the core to form the current host, path, url, etc. are not filled (correctly).

If this is the same problem as you experience then this issue is IMO a conceptual problem in EXT:solr.

#5 Updated by Alexander Opitz about 3 years ago

  • Status changed from Needs Feedback to Closed
  • Target version deleted (Candidate for patchlevel)

No feedback within the last 90 days => closing this issue.

If you think that this is the wrong decision or experience this issue again, then please write to the mailing list typo3.teams.bugs with issue number and an explanation or open a new ticket and add a relation to this ticket number.

Also available in: Atom PDF