Feature #72908

Backend: Repositioning the page after a button is used

Added by Kurt Ludikovsky almost 5 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2016-01-24
Due date:
% Done:

0%

Estimated time:
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

Whenever one is going to activate a buttone, e.g. a hide/unhide of a content element, the page is updated and repositioned to the top of the page.

This requires that one has to scroll down to the content again.
This is annoying.

Desired state:

Either there is no reload of the page when there is no necessity, or
the page is repositioned to the position where the acitvated button was situated.

I have no idea, if an how this could be done, but I can imagine that this can be done by ajax or href's.


Related issues

Related to TYPO3 Core - Bug #70074: After saving tt_content, always jumps to topClosed2015-09-24

Actions
Related to TYPO3 Core - Feature #75462: Retain scroll position after deleting/hiding a content elementNew2016-04-08

Actions
Related to TYPO3 Core - Feature #78931: Use ajax in place of page refresh for more actions in the backendNew2016-12-09

Actions
#1

Updated by Riccardo De Contardi almost 5 years ago

Can be considered the same issue as #70074 ?

#2

Updated by Kurt Ludikovsky almost 5 years ago

I would consider this something related but not a duplicate.
#70074 talks about saving.

This is about e.g. just klicking the hide/unhide button from content elements in page view.

So both are about the jumping to the top-of-page everytime, but refer to different items.

#3

Updated by Riccardo De Contardi almost 3 years ago

  • Related to Feature #78931: Use ajax in place of page refresh for more actions in the backend added
#4

Updated by Riccardo De Contardi almost 3 years ago

  • Status changed from New to Closed

I think I can close this issue as a duplicate of #78931; I've added a reference to this issue to keep track of it.

if you think that this is the wrong decision please reopen it or ping me.

Thank you.

Also available in: Atom PDF