Bug #73733

CONTENTs slide.collect = -1 is not working correctly

Added by Christian Stern over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Start date:
2016-02-29
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

The slide.collect property is not working like expected. I set up a t3d file to demonstrate the false behaviour and attached it. Just import it in a blank master version of typo3.

When using CONTENTs slide.collect = -1 to retrive all contents of a specified colPos the ouput is false. It seems that the content of the root page occurs the times pages/levels are present.

The behaviour only occurs in the current 7.6 Version. <= 6.2 is not effected.

Example-Setup:

Pages:

  • Page root
  • * Page level 1
  • * * Page level 2

Content:
Each page has a text-content inside colPos 3.

Exmaple typoscript:

html = PAGE
html {
  10 = HMENU
  10 {
    special = list

    1 = TMENU
    1 {
      expAll = 1
      NO = 1
      NO.wrapItemAndSub = <div>|</div>
    }

    2 < .1
    3 < .1
  }

  20 = CONTENT
  20 {
    table = tt_content
    slide = -1
    slide.collect = -1

    select.where = colPos = 3

    renderObj = COA
    renderObj {
      10 = TEXT
      10 {
        field = header
        stdWrap {
          required = 1
          wrap = <h3>|</h3>
        }
      }

      20 = TEXT
      20 {
        field = bodytext
      }
    }
  }
}

The Output in 7.6 on page Level 2:

Item on level 2

Item on level 1

Item on root

Item on root

Item on root

The Output in 6.2 on page Level 2:

Item on level 2

Item on level 1

Item on root

T3D__2016-02-29_09-27-z.t3d - Complete t3d-export to deomstrate the false behaviour (3.17 KB) Christian Stern, 2016-02-29 10:28


Related issues

Related to TYPO3 Core - Bug #69941: slide of cObject CONTENT don't work properly Closed 2015-09-18

History

#1 Updated by Chris topher over 3 years ago

  • Project changed from TSconfig to TYPO3 Core
  • TYPO3 Version set to 7
  • Is Regression set to No

Moving this bug report to the Core project.

#2 Updated by Jo Hasenau over 3 years ago

  • Assignee set to Jo Hasenau

#3 Updated by Riccardo De Contardi over 3 years ago

  • Target version changed from 7 to Candidate for patchlevel

#4 Updated by Oliver Hader about 3 years ago

Could not reproduce the behavior with the provided T3D file in 8.2.0 (8.3.0-dev) nor in 7.6.10-dev...

#5 Updated by Peter Foerger about 3 years ago

Can't reproduce in 8.3.0-dev.

#6 Updated by Hannes Leutloff about 3 years ago

Can't reproduce in 7.6.9.

#7 Updated by Oliver Hader about 3 years ago

@Christian, can you please check, whether this behavior is still present with recent 7.6 or CMS 8 versions? Thanks in advance!

#8 Updated by Oliver Hader about 3 years ago

  • Status changed from New to Needs Feedback

#9 Updated by Christian Stern about 3 years ago

Oliver Hader wrote:

@Christian, can you please check, whether this behavior is still present with recent 7.6 or CMS 8 versions? Thanks in advance!

I can not reproduce this behaviour anymore. Seems to be fixed since #69941 was resolved!

#10 Updated by Riccardo De Contardi about 3 years ago

  • Status changed from Needs Feedback to Closed
  • Assignee deleted (Jo Hasenau)

I close this as resolved; thank you for your feedback!

If you think that this is the wrong decision or experience the issue again, please open a new issue with a reference to this one. Thanks again!

Also available in: Atom PDF