Project

General

Profile

Actions

Bug #73800

closed

Edting in Pagetree Overview throws exception when root page is involved

Added by Jo Hasenau over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2016-03-01
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.5
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In the info module there the "Pagetree Overview" that shows a tree of pages with the selected page as root. You can click on several pencil icons there to edit either a single page or mass edit a particular field of all pages currently shown in that tree.

As soon as the root page of that view is the actual root page (0) of your real page tree, both the pencil icon of that particular page and the mass editing of all fields throw an exception.

Uncaught TYPO3 Exception
#1437656456: $uid must be positive integer, 0 given (More information)

IN CMS 6.2 there is just an error message instead of an exception, so the rest of the actions will be executed as expected.
Just the root page is excluded from the list of mass editing form fields then, which is what I would expect in CMS 7 as well.


Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #77678: Editing via Info > Pagetree Overview fails if uid is 0 anywhereClosedAndreas Kienast2016-08-29

Actions
Actions #1

Updated by Jo Hasenau over 8 years ago

  • Description updated (diff)
Actions #2

Updated by Tom Warwick about 8 years ago

Getting the same issue in 7.6.5 also.

Actions #3

Updated by Anu Bhuvanendran Nair about 8 years ago

In the page module when translations are created for image contents, while editing the image inside the content the same error jumps up. I'm using TYPO3 7.6.5

Actions #4

Updated by Riccardo De Contardi almost 8 years ago

  • Category set to Backend User Interface

Still present on 8.2-dev (latest master)

Actions #5

Updated by Robert Gonda almost 8 years ago

+1 Typo3 7.6.9

Actions #6

Updated by Tymoteusz Motylewski almost 8 years ago

  • Status changed from New to Closed

seems to be fixed already in #77678
if not please let us know

Actions

Also available in: Atom PDF