Bug #75585

"PHP Warning: array_replace_recursive() recursion detected" on rendering under PHP 7

Added by BENCH Artwork over 5 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2016-04-14
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
7.0
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

i get following PHP warning under PHP 7 on the first rendering after clearing the cache:

#1: PHP Warning: array_replace_recursive(): recursion detected in /home/xxx/public_html/typo3_src-7.6.5/typo3/sysext/frontend/Classes/ContentObject/ContentObjectRenderer.php line 838

the used typoscript inside an gridelements column that caused the error:

3 < lib.gridelements.defaultGridSetup
    3 {

        wrap = <div class="accordion">|</div>
        columns {
            10 < .default

            10.renderObj.20 {
                stdWrap.innerWrap.cObject.default.20.10.default.noTrimWrap = |acc_box| |
                text.10 = < lib.stdheader
                text.10 {
                    3 = LOAD_REGISTER
                    3 {
                        headerClass.cObject = COA
                        headerClass.cObject {
                            30 = TEXT
                            30.value =
                            30.noTrimWrap = | acc_trigger red| |
                        }
                    }
                }
                text.20.wrap = <div class="acc_content">|</div>
            }
        }
    }

on PHP 5.6 it's all fine.


Files

TYPO3 Exception.html (37.2 KB) TYPO3 Exception.html BENCH Artwork, 2016-04-14 09:14

Related issues

Related to TYPO3 Core - Bug #73542: PHP Warning: array_replace_recursive(): Argument #1 is not an arrayClosed2016-02-18

Actions
#1

Updated by Paul Kamma about 5 years ago

So are there any Updates on this Issue? It's really annoying.
I updated to 7.6.9 but the Error still appear!

#2

Updated by Riccardo De Contardi almost 5 years ago

  • Category set to Frontend
#3

Updated by Georg Ringer almost 3 years ago

  • Status changed from New to Closed

couldn't reproduce that on 8 or 9, therefore I am closing this issue

Also available in: Atom PDF