Project

General

Profile

Actions

Bug #73542

closed

PHP Warning: array_replace_recursive(): Argument #1 is not an array

Added by Thomas Sperling over 8 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-02-18
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:
On Location Sprint

Description

Hi I have the same problem as in #63701.
But now in sysext/css_styled_content/Classes/Controller/CssStyledContentController.php

It occurs sometimes in Frontend. If I clear the cache its gone, but after some time its back.

Error happend in 7.6.2 and 7.6.3


Files

TYPO3 Exception.htm (33.7 KB) TYPO3 Exception.htm ErrorLog Paul Kamma, 2016-06-29 18:11

Related issues 1 (0 open1 closed)

Related to TYPO3 Core - Bug #75585: "PHP Warning: array_replace_recursive() recursion detected" on rendering under PHP 7Closed2016-04-14

Actions
Actions #1

Updated by Thomas Sperling over 8 years ago

Sorry, I was a little to fast.
It is not the same error. I get #1: PHP Warning: array_replace_recursive(): recursion detected. So sadly its not that easy solved.

The actual Code is Line 475 (TYPO3 7.6.3)

// Specific configuration for the chosen rendering method
if (is_array($conf['rendering.'][$renderMethod . '.'])) {
   $conf = array_replace_recursive($conf, $conf['rendering.'][$renderMethod . '.']);
}

Actions #2

Updated by Paul Kamma about 8 years ago

Any Updates on this Critical Issue?! :/
I updated to 7.6.9 but the Error still appear! After a Cache Clear the Error appears.
PHP 7.0.4-7ubuntu2.1
Added my Errorlog.

Actions #3

Updated by Benni Mack almost 7 years ago

  • Status changed from New to Needs Feedback

Does this still occur with TYPO3 7.6.23?

Actions #4

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Needs Feedback to Closed

90 days without feedback -> closing it.

If you think that this is the wrong decision or experience the issue again or have more information about how to reproduce it, please reopen it or open a new issue with a reference to this one. Thank you.

Actions #5

Updated by Jonathan IROULIN over 6 years ago

Riccardo De Contardi wrote:

90 days without feedback -> closing it.

If you think that this is the wrong decision or experience the issue again or have more information about how to reproduce it, please reopen it or open a new issue with a reference to this one. Thank you.

Hello,
It still occur with TYPO3 7.6.26

30-03-18 16:01 - core: Core: Error handler (FE): PHP Warning: array_replace_recursive(): recursion detected in /var/www/usmig.local.typo3.org/TYPO3_sources/typo3_src-7.6.26/typo3/sysext/frontend/Classes/ContentObject/ContentObjectRenderer.php line 838
Actions #6

Updated by Riccardo De Contardi over 6 years ago

  • Status changed from Closed to New
Actions #7

Updated by Susanne Moog over 5 years ago

  • Sprint Focus set to On Location Sprint
Actions #8

Updated by Benni Mack over 5 years ago

  • Status changed from New to Needs Feedback

Could anyone provide some more information on how to reproduce this issue? Do you have some special TypoScript content rendering definitions?

Actions #9

Updated by Thomas Sperling over 5 years ago

I have no TYPO3-System with this error anymore. So for me the ticket could be closed (somehow I cannot close this ticket).
I tried to get feedback from Jonathan, but no answer.

Actions #10

Updated by Riccardo De Contardi about 5 years ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Actions

Also available in: Atom PDF