Bug #76944

Subrequest-integrity should also add cross-origin header

Added by Tim Riemenschneider about 5 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-07-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

In Feature #66698 the integrity-property was added to PAGE.includeJS (and similar).

However (at least with newer chrome-versions) with this the resources are not loaded anymore, because a crossorigin attribute is required together with integrity, the error-log displays:

Hacking the Pagerenderer solves this, see attached patch, which simpy adds 'crossorigin="anonymous"'. However even better would be to make that configurable.


Files

integrity-workaround.patch (2.07 KB) integrity-workaround.patch Tim Riemenschneider, 2016-07-05 16:03
integrity-attr-needs-cross-origin-attr.png (5.75 KB) integrity-attr-needs-cross-origin-attr.png Tim Riemenschneider, 2016-07-05 16:03

Related issues

Related to TYPO3 Core - Feature #66698: Add integrity property to JavaScript filesClosedXavier Perseguers2015-05-01

Actions
Is duplicate of TYPO3 Core - Feature #76459: Add crossorigin property to JavaScript filesClosedJacob Dreesen2016-06-05

Actions
#1

Updated by Wouter Wolters about 5 years ago

  • Status changed from New to Rejected

I close this ticket as a duplicated of #7645
Please continue there.

#2

Updated by Mathias Brodala almost 5 years ago

Wouter Wolters wrote:

I close this ticket as a duplicated of #7645
Please continue there.

Could you check that ticket number? I just created #77873 due to the same issue.

#3

Updated by Tim Riemenschneider almost 5 years ago

There seems to be a "9" missing, the ticket should be 76459 (as already mentioned above in "Related issues" ;-) )

#4

Updated by Mathias Brodala almost 5 years ago

Tim Riemenschneider wrote:

There seems to be a "9" missing, the ticket should be 76459 (as already mentioned above in "Related issues" ;-) )

Yeah, noticed that in the meantime, thanks anyways. ;-)

Also available in: Atom PDF