Bug #77664

Search in translation in list view

Added by Ruud Silvrants over 3 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-08-29
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When searching in the list view and "Localization view" is selected, translated items aren't found.

When you disable "Localization view" items are found.

nimbus-image-1472474354270.png View (39.2 KB) Ruud Silvrants, 2016-08-29 14:42

SC_NEW.JPG View (45.4 KB) Lukas Taferner, 2016-10-12 13:10

SC_OLD.JPG View (69.2 KB) Lukas Taferner, 2016-10-12 13:10

oldSearch.PNG View (37.4 KB) Jörg Velletti, 2016-10-20 18:16

actualSearch.PNG View (11.3 KB) Jörg Velletti, 2016-10-20 18:16

searchForGermanWord.PNG View (16.3 KB) Jörg Velletti, 2016-10-20 18:16

Associated revisions

Revision 67b664fc (diff)
Added by Frans Saris over 3 years ago

[BUGFIX] Search also in translated records

When localisation view is enabled in the list view make sure
also the translated records are searched.

Resolves: #77664
Releases: master, 7.6
Change-Id: Ica285db7b410b703b968bcf9f4db1fd797f6b171
Reviewed-on: https://review.typo3.org/49668
Tested-by: Bamboo TYPO3com <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Daniel Goerz <>
Tested-by: Daniel Goerz <>
Reviewed-by: Daniel Maier <>
Tested-by: Daniel Maier <>
Reviewed-by: Andreas Wolf <>
Tested-by: Andreas Wolf <>

Revision 83af8a9a (diff)
Added by Frans Saris over 3 years ago

[BUGFIX] Search also in translated records

When localisation view is enabled in the list view make sure
also the translated records are searched.

Resolves: #77664
Releases: master, 7.6
Change-Id: Ica285db7b410b703b968bcf9f4db1fd797f6b171
Reviewed-on: https://review.typo3.org/49826
Tested-by: Bamboo TYPO3com <>
Reviewed-by: Frans Saris <>
Tested-by: Frans Saris <>

History

#1 Updated by Frans Saris over 3 years ago

  • Description updated (diff)

#2 Updated by Frans Saris over 3 years ago

This is also broken for 6.2

#3 Updated by Gerrit Code Review over 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49668

#4 Updated by Gerrit Code Review over 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49668

#5 Updated by Gerrit Code Review over 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49668

#6 Updated by Gerrit Code Review over 3 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49668

#7 Updated by Frans Saris over 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#8 Updated by Gerrit Code Review over 3 years ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_7-6 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/49826

#9 Updated by Frans Saris over 3 years ago

  • Status changed from Under Review to Resolved

#10 Updated by Lukas Taferner about 3 years ago

Unfortunately this patch completely changes the behaviour of the search in the list-view (please check the attached screenshots). Translations of Records with 'l10n_display' = 'defaultAsReadonly' are not shown any more.

#11 Updated by Lukas Taferner about 3 years ago

#12 Updated by Frans Saris about 3 years ago

Hi Lukas,

this indeed looks like a change in behavior. But the search is now more predictable for the editors than before.
In your use-case the translations are shown because the record of the default language matches your search and not because the translated record matches your search.

Groet Frans

#13 Updated by Jörg Velletti about 3 years ago

Frans Saris wrote:

Hi Lukas,

this indeed looks like a change in behavior. But the search is now more predictable for the editors than before.
In your use-case the translations are shown because the record of the default language matches your search and not because the translated record matches your search.

Groet Frans

can someone explain me why line 771 in DatabaseRecordList.php was Changed during this BugFix ?

before this patch:
if ($this->localizationView && $l10nEnabled ) {

after this patch:
if ($this->localizationView && $l10nEnabled && $this->searchString === '') {

All other changes in that patch looks logical to me, but this change, changes the behavior:

in my Case:
a backend editor wants to change the image of a specific translated entry, in the past he could search for a word in the default language and had, in localisation View, all Translated Records of this search hit attached.

So he does not need to know the translation of his search word in Russian (what he does not understand) but is able to change the image in all Translations of this. Now he hast do do (with 8 translations) do 8 Searches or needs to know the ID

Reverting just this line, i get back the old behavior and also this bug #77664 is fixed a nd i cant see a negative effect.

#14 Updated by Jörg Velletti about 3 years ago

PS: there is no diffence between activation of option "Localisation View" or not
See images:
actualSearch ,

and when reverting that line:
i get "oldSearch" Result for englisch words and can also Search for translated Records "searchForGermanWord"

#15 Updated by Frans Saris about 3 years ago

That check is there to prevent that a record is shown 2 times.
1st time because the search matched, 2th because the translated record is added there

#16 Updated by Jörg Velletti about 3 years ago

Thanks for the confirmation.
Yesterday i though that this situation will not happen, but i build a scenario and you are right.

I explained it to the backend editor and he accepted the new situation ...

#17 Updated by Benni Mack about 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF