Bug #78316

Epic #65814: Make Indexed search extbase plugin shine

Regression: Wrong link to normal search mode if advanced mode is active by default

Added by Online Now! GmbH about 4 years ago. Updated 11 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2016-10-17
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
7
PHP Version:
5.6
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

I am currently upgrading an old TYPO3 4.5 installation to 7.6 LTS and noticed a wrong behaviour in the indexed_search extension. In ticket #51189 and #61982 was a change made to remove the link parameter for the normal search if the advanced search mode is active. The problem with this change is, it does not consider the possibility that the advanced search is active by default ( activated by _DEFAULT_PI_VARS.ext=1 in TypoScript ). In that case, the link back to normal mode does not get the necessary parameter so switching backing to normal mode with the link in the marker ###LINKTOOTHERMODE### is simply not possible.

Since there are no hook or other TypoScript options available, my only chance is to use an xclass or change the core file.

It would be nice if there are some more options to create the correct link or revert the previous change. The argument in #51189 about duplicate content is no argument in my opinion because you can use a canonical url or use noindex,nofollow on the search page.

The problem occurs in 6.2 and most likey in 8 as well.


Related issues

Related to TYPO3 Core - Bug #51189: Remove non-needed Url parameter for standard searchClosed2013-08-19

Actions
Related to TYPO3 Core - Bug #61982: Regression fix for wrong backport of indexed_search patch #51189ClosedMarkus Klein2014-09-30

Actions
#1

Updated by Riccardo De Contardi over 1 year ago

  • Parent task set to #65814
#2

Updated by Benni Mack 11 months ago

  • Related to Bug #51189: Remove non-needed Url parameter for standard search added
#3

Updated by Benni Mack 11 months ago

  • Related to Bug #61982: Regression fix for wrong backport of indexed_search patch #51189 added
#4

Updated by Benni Mack 11 months ago

  • Status changed from New to Closed

Hey,

I'm closing this issue. The pi-based plugin is fully removed since a couple of versions, and we only support the Fluid-baed templates where you can change the links in templates to be easily overridable. If you feel we're still missing something, let me know and I will re-open the issue.

Also available in: Atom PDF