Bug #78629

Updating reference indexes during record operations consumes thousands of SQL queries

Added by Claus Due about 3 years ago. Updated over 2 years ago.

Status:
Rejected
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2016-11-09
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When the DataHandler is allowed to update reference indexing and is asked to do recursive copy operations, it triggers thousands upon thousands of SQL queries even for a limited set (26 pages, ~100 content records, no translations).

It would be wise to add a configuration option to disable this forced reference index updating, and follow that up with a scheduler task to update all reference indexes without slowing down record operations. The option itself can be allowed on 7.6 LTS to be used by site administrators who are able to take the necessary precautions to update the index.

History

#1 Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50559

#2 Updated by Gerrit Code Review about 3 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50559

#3 Updated by Gerrit Code Review about 3 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/50559

#4 Updated by Anja Leichsenring almost 3 years ago

  • Status changed from Under Review to Rejected

#5 Updated by José Ricardo over 2 years ago

Why was this rejected? I have a similar problem at #80800

#6 Updated by Wouter Wolters over 2 years ago

From the Gerrot review:

Abandoned

Since four people now mentioned their concerns on disabling the reference index, I'm closing this change. It's more a candidate for a custom and local XCLASS instead of adding side-effects to the TYPO3 core. Thanks for your understanding...

Also available in: Atom PDF