Bug #79094

Extension Manager API potentially makes destructive database schema changes

Added by Helmut Hummel over 2 years ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Extension Manager
Target version:
-
Start date:
2016-12-25
Due date:
% Done:

100%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

Szenario:

An extension (ext_test) changes the schema for table pages by increasing the field size of author_email to varchar(255). The core extension defines a size of varchar(80) for this field.

Steps to reproduce:
  • when I install the extension using the extension manager
  • and execute the command on command line typo3/cli_dispatch.phpsh extbase extension:install core

Expected result:
I expect the database schema to not have changed

Actual result:
The field size of author_email in table pagesis reduced to varchar(80)
This can be verified in the install tool with the database compare tool

ext_test_0.1.0_201701132110.zip - Extension 1 (615 Bytes) Helmut Hummel, 2017-01-13 21:12

ext_test1_0.1.0_201701132111.zip - Extension 2 (depends on Extension 1) (598 Bytes) Helmut Hummel, 2017-01-13 21:12


Related issues

Related to TYPO3 Core - Task #83986: Streamline size of all email fields at the database schema Closed 2018-02-20
Precedes TYPO3 Core - Bug #85915: Exception on attempt to update a static database table in extension manager Closed

Associated revisions

Revision aa5ccf0e (diff)
Added by Nicole Cordes about 1 year ago

[BUGFIX] Update complete database after extension installation

If an extension and its dependencies get installed, the whole
database needs to be updated instead of executing each extensions
SQL on its own.

Resolves: #79094
Releases: master, 8.7
Change-Id: I9a870e0efb6af241eeae563adbaa14af100edaec
Reviewed-on: https://review.typo3.org/57429
Tested-by: TYPO3com <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>
Reviewed-by: Daniel Goerz <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

Revision a8d51b4a (diff)
Added by Nicole Cordes about 1 year ago

[BUGFIX] Update complete database after extension installation

If an extension and its dependencies get installed, the whole
database needs to be updated instead of executing each extensions
SQL on its own.

Resolves: #79094
Releases: master, 8.7
Change-Id: I9a870e0efb6af241eeae563adbaa14af100edaec
Reviewed-on: https://review.typo3.org/57486
Tested-by: TYPO3com <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

Revision ff4341c5 (diff)
Added by Stephan Großberndt about 1 year ago

[BUGFIX] Use extension key instead of an array for data reload

Due to some database changes during the installation process of an
extension, the patch https://review.typo3.org/57486/ misses to pass
the extension key instead of the enriched extension information array.

Resolves: #85915
Related: #79094
Releases: master, 8.7
Change-Id: I708a99f47a2c493f68d224b9ffca4ec6c008f827
Reviewed-on: https://review.typo3.org/57979
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>
Reviewed-by: Joerg Kummer <>
Tested-by: Joerg Kummer <>
Tested-by: TYPO3com <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

Revision 66282d21 (diff)
Added by Stephan Großberndt about 1 year ago

[BUGFIX] Use extension key instead of an array for data reload

Due to some database changes during the installation process of an
extension, the patch https://review.typo3.org/57486/ misses to pass
the extension key instead of the enriched extension information array.

Resolves: #85915
Related: #79094
Releases: master, 8.7
Change-Id: I708a99f47a2c493f68d224b9ffca4ec6c008f827
Reviewed-on: https://review.typo3.org/57981
Reviewed-by: Joerg Kummer <>
Tested-by: Joerg Kummer <>
Tested-by: TYPO3com <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

History

#1 Updated by Helmut Hummel over 2 years ago

  • Category set to Extension Manager
  • Assignee set to Nicole Cordes

#2 Updated by Helmut Hummel over 2 years ago

  • Status changed from New to Accepted

#3 Updated by Helmut Hummel over 2 years ago

  • File deleted (ext_test.zip)

#6 Updated by Helmut Hummel over 2 years ago

This bug is even easier to trigger:

  1. Install both extensions
  2. On database level add a long string to table "pages" in field "tx_ext_test"
  3. Re-upload ext_test and confirm overwrite

Expected result: Data in tx_ext_test is fine

Actual result: Data in tx_ext_test is truncated to 10 characters

#7 Updated by Guido S. over 1 year ago

  • Related to Task #83986: Streamline size of all email fields at the database schema added

#8 Updated by Gerrit Code Review about 1 year ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57429

#9 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57429

#10 Updated by Gerrit Code Review about 1 year ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57429

#11 Updated by Gerrit Code Review about 1 year ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57429

#12 Updated by Gerrit Code Review about 1 year ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57429

#13 Updated by Gerrit Code Review about 1 year ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57429

#14 Updated by Gerrit Code Review about 1 year ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57429

#15 Updated by Gerrit Code Review about 1 year ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57429

#16 Updated by Gerrit Code Review about 1 year ago

Patch set 9 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57429

#17 Updated by Gerrit Code Review about 1 year ago

Patch set 10 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57429

#18 Updated by Nicole Cordes about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#19 Updated by Gerrit Code Review about 1 year ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57486

#20 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57486

#21 Updated by Nicole Cordes about 1 year ago

  • Status changed from Under Review to Resolved

#22 Updated by Stephan Großberndt about 1 year ago

  • Precedes Bug #85915: Exception on attempt to update a static database table in extension manager added

#23 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF