Bug #85915

Exception on attempt to update a static database table in extension manager

Added by Dima Nozdrin about 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Extension Manager
Target version:
-
Start date:
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.1
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

On attempt to update a static database table in extension manager an exception is thrown #1342864081: Extension Array is not available (see screenshot).
Tested on 8.7.17 and don't seem to be fixed in 8.7.18 and 8.7.19

Can be fixed by changing

$this->installUtility->processExtensionSetup($extension);

to
$this->installUtility->processExtensionSetup($extension['key']);

in typo3/sysext/extensionmanager/Classes/Controller/ActionController.php on line 193

extension manager bug.jpg View (401 KB) Dima Nozdrin, 2018-08-21 09:51


Related issues

Related to TYPO3 Core - Bug #85785: EXT:extensionmanager cannot reload static database data over 8.7.18 Closed 2018-08-08
Related to TYPO3 Core - Bug #86578: Since Typo3 8.7.17 execute ext_tables_static+adt.sql is broken Closed 2018-10-05
Follows TYPO3 Core - Bug #79094: Extension Manager API potentially makes destructive database schema changes Closed 2016-12-25

Associated revisions

Revision ff4341c5 (diff)
Added by Stephan Großberndt about 1 year ago

[BUGFIX] Use extension key instead of an array for data reload

Due to some database changes during the installation process of an
extension, the patch https://review.typo3.org/57486/ misses to pass
the extension key instead of the enriched extension information array.

Resolves: #85915
Related: #79094
Releases: master, 8.7
Change-Id: I708a99f47a2c493f68d224b9ffca4ec6c008f827
Reviewed-on: https://review.typo3.org/57979
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>
Reviewed-by: Joerg Kummer <>
Tested-by: Joerg Kummer <>
Tested-by: TYPO3com <>
Reviewed-by: Helmut Hummel <>
Tested-by: Helmut Hummel <>

Revision 66282d21 (diff)
Added by Stephan Großberndt about 1 year ago

[BUGFIX] Use extension key instead of an array for data reload

Due to some database changes during the installation process of an
extension, the patch https://review.typo3.org/57486/ misses to pass
the extension key instead of the enriched extension information array.

Resolves: #85915
Related: #79094
Releases: master, 8.7
Change-Id: I708a99f47a2c493f68d224b9ffca4ec6c008f827
Reviewed-on: https://review.typo3.org/57981
Reviewed-by: Joerg Kummer <>
Tested-by: Joerg Kummer <>
Tested-by: TYPO3com <>
Reviewed-by: Nicole Cordes <>
Tested-by: Nicole Cordes <>

History

#1 Updated by Joerg Kummer about 1 year ago

I can confirm.

#2 Updated by Stephan Großberndt about 1 year ago

  • Description updated (diff)
  • Target version deleted (8.7.19)

#3 Updated by Stephan Großberndt about 1 year ago

  • Description updated (diff)

#5 Updated by Stephan Großberndt about 1 year ago

  • Due date set to 2016-12-26
  • Start date changed from 2018-08-21 to 2016-12-26
  • Follows Bug #79094: Extension Manager API potentially makes destructive database schema changes added

#6 Updated by Stephan Großberndt about 1 year ago

  • Status changed from New to In Progress
  • Priority changed from Should have to Must have

#7 Updated by Gerrit Code Review about 1 year ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57979

#8 Updated by Stephan Großberndt about 1 year ago

  • Due date deleted (2016-12-26)
  • Start date deleted (2016-12-26)

#9 Updated by Stephan Großberndt about 1 year ago

Can be tested easily by installing EXT:static_info_tables and updating static data in extension manager (last icon)

#10 Updated by Gerrit Code Review about 1 year ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57979

#11 Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57980

#12 Updated by Gerrit Code Review about 1 year ago

Patch set 1 for branch TYPO3_8-7 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/57981

#13 Updated by Stephan Großberndt about 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Oliver Hader about 1 year ago

  • Is Regression changed from No to Yes

#15 Updated by Sergio Catalá about 1 year ago

  • Related to Bug #85785: EXT:extensionmanager cannot reload static database data over 8.7.18 added

#16 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

#17 Updated by Georg Ringer 12 months ago

  • Related to Bug #86578: Since Typo3 8.7.17 execute ext_tables_static+adt.sql is broken added

Also available in: Atom PDF