Bug #79108

Indexed Search cHash calculation error when indexing a single record

Added by Matthias Toscanelli almost 4 years ago. Updated 9 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
2016-12-29
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Is Regression:
No
Sprint Focus:

Description

When TYPO3 is configured to index single record (eg: news) and cHash parameter is checked, we get this error:

Core: Exception handler (WEB): Uncaught TYPO3 Exception: #1467983513: ID parameter needs to be passed for the cHash calculation! 
As a temporary not recommended workaround, you can set $GLOBALS['TYPO3_CONF_VARS']['FE']['cHashIncludePageId'] to false to avoid 
this error. | RuntimeException thrown in file xxxxxx/typo3_src-8.5.0/typo3/sysext/frontend/Classes/Page/CacheHashCalculator.php 
in line 136.

The reason is that parameter "id" is not sent to CacheHashCalculator when Indexer generate the cHash.
I am not sure where to fixe this, in Indexer (line 372) or in CrawlerHook (line 676)

A temporary workaround is to add the "id=xx" to GETparameter in configuration.


Related issues

Related to TYPO3 Core - Task #88741: Remove cHash calculation in indexed searchClosedBenni Mack2019-07-13

Actions
Related to TYPO3 Core - Task #80050: Remove option cHashIncludePageId from cHash calculationClosedBenni Mack2017-02-28

Actions
#1

Updated by Matthias Toscanelli almost 4 years ago

TYPO3 v7.6 should be also affected (not tested)

#2

Updated by Tymoteusz Motylewski almost 4 years ago

  • Category set to Indexed Search
#3

Updated by Susanne Moog 9 months ago

  • Related to Task #88741: Remove cHash calculation in indexed search added
#4

Updated by Susanne Moog 9 months ago

  • Related to Task #80050: Remove option cHashIncludePageId from cHash calculation added
#5

Updated by Susanne Moog 9 months ago

  • Status changed from New to Closed

Has been fixed / rewritten with #88741.

Also available in: Atom PDF